Mathematica 9 is now available
Services & Resources / Wolfram Forums
-----
 /
MathGroup Archive
1993
*January
*February
*March
*April
*May
*June
*July
*August
*September
*October
*November
*December
*Archive Index
*Ask about this page
*Print this page
*Give us feedback
*Sign up for the Wolfram Insider

MathGroup Archive 1993

[Date Index] [Thread Index] [Author Index]

Search the Archive

Series Expansion Inconsistency

  • To: mathgroup at yoda.physics.unc.edu
  • Subject: Series Expansion Inconsistency
  • From: Cetin Cetinkaya <cetin at acm0.me.uiuc.edu>
  • Date: Mon, 19 Apr 1993 20:19:27 -0500

 Hello;

While I am trying to do some perturbation analysis, I run into a peculiar
behaviour. My function k looks like 



In[31]:= k
0. Second  1928.568 KByte

                             3 - n                  3 - n
                     (c1 eps)      - (c20 + c21 eps)
Out[31]= -------------------------------------------------------------
                                         2 - n                  2 - n
         c1 eps (c20 + c21 eps) ((c1 eps)      - (c20 + c21 eps)     )  




For n=19, I expand the function k with respect to eps up to eps^2 and 
collect the coefficients of eps: 



In[32]:= Collect[Simplify[Normal[Series[k/.n->19,{eps,0,2}]]] ,eps]
3.15 Second  1929.216 KByte

          1
Out[32]= ---
         c20  



This simply means that the expansion does not have eps or eps^2 orders
terms. However, When I tried the following to see how the eps^3 order
term looks like, I have got this:



In[33]:= Collect[Simplify[Normal[Series[k/.n->19,{eps,0,3}]]] ,eps]
3.81667 Second  1930.156 KByte

                            2    2      3    3
          1    c21 eps   c21  eps    c21  eps
Out[33]= --- - ------- + --------- - ---------
         c20       2          3           4
                c20        c20         c20    


To my suprise, this expression has order eps and eps^2 terms. Could any
one explain what is going on?  
The Mathematica verson I am running is 2.1.

Cetin







  • Prev by Date: Question about Display
  • Next by Date: Mathieu
  • Previous by thread: Re: Question about Display
  • Next by thread: Mathieu