Mathematica 9 is now available
Services & Resources / Wolfram Forums
-----
 /
MathGroup Archive
1996
*January
*February
*March
*April
*May
*June
*July
*August
*September
*October
*November
*December
*Archive Index
*Ask about this page
*Print this page
*Give us feedback
*Sign up for the Wolfram Insider

MathGroup Archive 1996

[Date Index] [Thread Index] [Author Index]

Search the Archive

Loading packages w/o write access

  • To: mathgroup at smc.vnet.net
  • Subject: [mg4473] Loading packages w/o write access
  • From: Ruby Tuesday <hopie at mnovi.bevc.blacksburg.va.us>
  • Date: Mon, 29 Jul 1996 02:37:26 -0400
  • Sender: owner-wri-mathgroup at wolfram.com

 
I am running mathematica on a multi-user unix machine (Sun and HP - account
on both).  I need to load several packages that are not in the /Packages
directory.  Since I do not have write access to that directory (and the
admins are to slow to add it in time), I was wondering how to load the
package from my home dir?

I have tried changing the working diretory, but it doesn't seem to stay
changed - even placing it in the same cell as my Get.  The closest I
have come in executing Get["/my/home/dir/PackageName.m"] but it didn't 
allow me to use the commands; it just didn't give an error either.

Also, could someone explain how to interpret <<Graphis`PackageName`?  I
am thinking Graphics is the subdirectory under packages, but then it
would seem I could do <<my/home/dir`Package` which doesn't work.  I even
tried changing the line in the package that says "Graphics`PackageName` to
many differnt things.  Well, to make a long stroy short, I spent about 5 
hours yesterday cursing at the computer.

The Mathematica Book suggested
reinstalling if $Path was not correct, since $Path was where it looked for
packages.  This is not an option.  Is there a .rc file I could change?
Is there any hope for me loading these packages or should I just go to the
computer lab?

Thank you very much!
Hope :)
 

==== [MESSAGE SEPARATOR] ====


  • Prev by Date: Re: Pairings
  • Next by Date: RE: help: Write data to file into many columns
  • Previous by thread: Re: Loading packages w/o write access
  • Next by thread: Matrices