Services & Resources / Wolfram Forums
-----
 /
MathGroup Archive
1997
*January
*February
*March
*April
*May
*June
*July
*August
*September
*October
*November
*Archive Index
*Ask about this page
*Print this page
*Give us feedback
*Sign up for the Wolfram Insider

MathGroup Archive 1997

[Date Index] [Thread Index] [Author Index]

Search the Archive

Q??: Solve::"eqf": "False is not a well-formed equation

  • To: mathgroup at smc.vnet.net
  • Subject: [mg8516] Q??: Solve::"eqf": "False is not a well-formed equation
  • From: Gadi Oron <oron at manet.pmmh.espci.fr>
  • Date: Thu, 4 Sep 1997 02:20:09 -0400
  • Organization: Acces regional Ile-de-France (Univ. Paris VI/VII) - France
  • Sender: owner-wri-mathgroup at wolfram.com

Hello all.

I have this strange behaviour of MMA that bugs me:

Solve[{0,0}==x {0.,1.}+{1.,1.}]

gives

Solve::eqf : False is not a well-formed equation.

But...

Solve[False]

gives (normal)

{}

and

Solve[{0,0}==x{0,1}+{1,1}]

gives (!!!)

{}

Can someone clear this point for me? Is there any way to get a {} in the
first case?

See ya.


/\/\/\/\/\/\/\/\/\/\/\/>> Gadi ORON <<\/\/\/\/\/\/\/\/\/\/\/\/\
| EMAIL :  oron at pmmh.espci.fr   ::::     oron at clipper.ens.fr  |
| Homepage : http://pmmh.espci.fr/~oron/personal.html         |
| fido : 2:325/302.8                                          |
| 		  Soyez braves - be brave.                    |
/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/




  • Prev by Date: Symbolic Curl
  • Next by Date: Re: lists of pairs
  • Previous by thread: Re: Symbolic Curl
  • Next by thread: Q: Union and precision.