MathGroup Archive 1998

[Date Index] [Thread Index] [Author Index]

Search the Archive

Re: Linux: couldn't reach []{} with latin2 keyboard layout


Davor Cengija <dcengija at public.srce.hr_OBRISI_.tel.hr> schrieb/wrote:
> I'm using Mathematica 3 on RH5.1 (2.0.35)
> 
> Since I live in Croatia, I need latin2 (iso-8859-2) keyboard layout to
> reach some ot the extended characters, which are settled on the places
> where reside {}[] characters in standard US keyboard layout.
> 
> I can reach those characters by typing Alt_Gr+(F,G,B,N) fot ([,],{,})
> and everything works fine except in Mathematica.
> 
> I tried with xmodmap and linked those characters on F9-F12 and it worked
> but now almost every other application makes compliances (as well as
> Mathematica).
> 
> Is there a way to make Mathematica to use latin2 keyboard layout?
> 
> Thanks
> 

I think you should edit the file KeyEventTranslations.tr located 
somewhere in ...mathematica/.. /FrontEnd. To add the translation for
"[" to come up with AltGr+F enter the following:

Item[KeyEvent["F",Modifiers->{Option}],
  FrontEndExecute[{
     FrontEnd`NotebookWrite[
       FrontEnd`SelectNotebook[],"[",After]}]]

Do this for all Keys you need.
I'm using Linux too, and I have to start Mathematica with the option
"-pureKeys" to make this work properly.

Hope this helps

es gruesst
      Peter

-- 
=--=--=--=--=--=--=--=--=--=--=--=--=--=--=--=--=--=--=--=--=--=--=--=
  P e t e r  B r e i t f e l d              eMail: phbrf at t-online.de
  Kreuzgasse 4, 88348 Saulgau, Germany      PGP public key: 08548045
=--=--=--=--=--=--=--=--=--=--=--=--=--=--=--=--=--=--=--=--=--=--=--=


  • Prev by Date: Mathematica - Which Version To Buy
  • Next by Date: Re: Mathematica 3.0 and QuickTime
  • Previous by thread: Mathematica - Which Version To Buy
  • Next by thread: Re: Linux: couldn't reach []{} with latin2 keyboard layout