Services & Resources / Wolfram Forums
-----
 /
MathGroup Archive
1999
*January
*February
*March
*April
*May
*June
*July
*August
*September
*October
*November
*December
*Archive Index
*Ask about this page
*Print this page
*Give us feedback
*Sign up for the Wolfram Insider

MathGroup Archive 1999

[Date Index] [Thread Index] [Author Index]

Search the Archive

GIF output in Mathematica 3.0

  • To: mathgroup at smc.vnet.net
  • Subject: [mg18376] GIF output in Mathematica 3.0
  • From: Tim Prescott <tprescott at orion.ac.hmc.edu>
  • Date: Wed, 30 Jun 1999 14:13:35 -0400
  • Sender: owner-wri-mathgroup at wolfram.com

I'm trying to write a mathlink program (on unix in c) that will output a
specified GIF.

For example, in the program I say:

MLEvaluateString(lp,"Display[\"full/path/name/testout.gif\",
Plot3D[Sin[x]Cos[y],{x,0,2Pi},{y,0,2Pi},DisplayFunction->Identity],\"GIF\"];");

When I run the program, the gif is not created. However, if I explicitly
start the kernel and call the function:

Display["full/path/name/testout.gif",
Plot3D[Sin[x]Cos[y],{x,0,2Pi},{y,0,2Pi},DisplayFunction->Identity],"GIF"];

the gif is correctly created.

Why is this happening, and (more importantly) how can I get the mathlink
program to correctly create the gif?

$Version = HP-UX PA-RISC 3.0 (October 4, 1996)
$ReleaseNumber = 0

Timothy Prescott






  • Prev by Date: Help
  • Next by Date: best line through a set of 3D points
  • Previous by thread: Help
  • Next by thread: best line through a set of 3D points