Services & Resources / Wolfram Forums
-----
 /
MathGroup Archive
2000
*January
*February
*March
*April
*May
*June
*July
*August
*September
*October
*November
*December
*Archive Index
*Ask about this page
*Print this page
*Give us feedback
*Sign up for the Wolfram Insider

MathGroup Archive 2000

[Date Index] [Thread Index] [Author Index]

Search the Archive

Re: "mma" becomes "Mathematica"

  • To: mathgroup at smc.vnet.net
  • Subject: [mg21510] Re: "mma" becomes "Mathematica"
  • From: "P.J. Hinton" <paulh at wolfram.com>
  • Date: Fri, 14 Jan 2000 02:43:28 -0500 (EST)
  • Organization: "Wolfram Research, Inc."
  • References: <85hvuj$1k8@smc.vnet.net>
  • Sender: owner-wri-mathgroup at wolfram.com

On 12 Jan 2000, Bjorn Leonardz wrote:

> When writing in a notebook it's enough to type "mma" to get "Mathematica".
> That's fine in English.
> 
> However, in Swedish it's a nuisance since there is a number of common verbs
> ending in "mma". Mathematica does not know about this so it still produces
> "Mathematica" in italics and all.
> 
> How can I turn this feature off?
> 
> OR better:
> 
> How can I change it so that it only occurs when I type "Mma" (with a
> capital M)?

This is controlled with the option InputAutoReplacements.  The Text cell
style, as defined in the Default.nb style sheet, has the following
suboptions as part of this option's value.

"mma"->"Mathematica" 
"Mma"->"Mathematica" 
"MMA"->"Mathematica"

You can disable this effect by removing these suboptions from the Text
cell prototype in your notebook's style sheet.

--
P.J. Hinton
Mathematica Programming Group           paulh at wolfram.com
Wolfram Research, Inc.
Disclaimer: Opinions expressed herein are those of the author alone.



  • Prev by Date: Re: Mathematica on Linux using KDE
  • Next by Date: Re: odd behaviour in rule delayed
  • Previous by thread: Training in Mathematica
  • Next by thread: Re: "mma" becomes "Mathematica"