MathGroup Archive 2002

[Date Index] [Thread Index] [Author Index]

Search the Archive

Re: aligning equations

  • To: mathgroup at
  • Subject: [mg36470] Re: aligning equations
  • From: Murray Eisenberg <murray at>
  • Date: Sun, 8 Sep 2002 03:30:48 -0400 (EDT)
  • Sender: owner-wri-mathgroup at

Your method 1), below, does not produce correct results if one then
uses menu>Save As Special>HTML+MathML.

I view the resulting .xml file in a MathML-enabled browser (e.g.,
Mozilla with appropriate TrueType fonts installed -- the four BaKoMa
cm fonts, the "old" Mathematica "Math1", etc., fonts, and the two MT
fonts.  Then the everything in the originally multi-line inline cell
appears on one line separate by a ?, as do the alignment markers.  In
the page source, these unrendered symbols have codes #8289 and #63328,

Is there an issue of the encoding used in the browser here?  I did try
Unicode-7, Unicode-8, and several of the "Western" encodings available
under Mozilla's Default Character Encoding.

Or is it something else?  Note that I do also have the "new"
Mathematica TrueType fonts ("Mathematica1", etc.).

P.S. I don't think Mathematica documents this, but if one wants a file
exported from Mathematica as HTML+MathML to be rendered correctly by a
browser, it seems to require an extension of .xml rather than .html.

Allan Hayes wrote:
 > "Mike" <mikeh1980 at> wrote in message
 > news:aiathf$5c1$1 at
 >>When writing a series of equations in mathematica (in a text cell)
  >>is there any way to align the equations at the "=" similar to
  >>what can be done in the equation editor made by math type (used
  >>in word etc.)?
 > Mike,
 > Two ways
 > 1) Start an inline cell in your text cell (menu>Edit>Expression
 > Inline Cell)
 > Type in your equations with the alignment marker (Esc am Esc) in
after each
 > equal sign.
 > Close the inline cell (menu>Edit>Expression Input>End Inline Cell).
 > Select the text cell (or the inline cell, though this is a delicate
 > operation, do it by repeatedly double clicking in it}.
 > Use menu> Format>Text Alignment>On Alignment Marker.
 > -- you will find that all single letters are now italic - you can
 > individual letters and change this - alternatively you can select
 > cell and use the option inspector (menu>Format>Option Inspector) to
 > SingleLetterItalics->False)
 > -- you can put existing text in an inline cell by selcting it and
 > menu>Edit>Expression Input>Start Inline Cell, but you  may have to
 > the line breaks after this.... 

  Murray Eisenberg                       Internet:  murray at
  Mathematics & Statistics Dept.            Voice:  413-545-2859 (W)
  University of Massachusetts                       413-549-1020 (H)
  Amherst, MA 01003                           Fax:  413-545-1801

  • Prev by Date: RE: Solve of inverse quadratic finite element problem - resend
  • Next by Date: Re: Re: word processing with mathematica
  • Previous by thread: Getting hierarchies of partitions
  • Next by thread: RE: Solve of inverse quadratic finite element problem - resend