MathGroup Archive 2002

[Date Index] [Thread Index] [Author Index]

Search the Archive

Mathematica 4.1 Config:Fonts


I've been trying to get my Mathematica 4.1 properly configured.  

I set:
###################################################################
/usr/local/mathematica/SystemFiles/FrontEnd/TextResources/X/Specific.tr:
  @@resource maxForXListFonts
  10000

# xlsfonts | wc -l
   5572

/etc/X11/XF86Config:
  FontPath      "/usr/X11R6/lib/X11/fonts/100dpi:unscaled"
  FontPath      "/usr/X11R6/lib/X11/fonts/75dpi:unscaled"
  FontPath      "/usr/X11R6/lib/X11/fonts/CID"
  FontPath      "/usr/X11R6/lib/X11/fonts/Speedo"
  FontPath      "/usr/X11R6/lib/X11/fonts/Type1"
  FontPath      "/usr/X11R6/lib/X11/fonts/URW"
  FontPath      "/usr/X11R6/lib/X11/fonts/kwintv:unscaled"
  FontPath      "/usr/X11R6/lib/X11/fonts/latin2/Type1"
  FontPath      "/usr/X11R6/lib/X11/fonts/local/mma/Type1"
  FontPath      "/usr/X11R6/lib/X11/fonts/local/mma/X:unscaled"
  FontPath      "/usr/X11R6/lib/X11/fonts/misc:unscaled"
  FontPath      "/usr/X11R6/lib/X11/fonts/misc/sgi:unscaled"
  FontPath      "/usr/X11R6/lib/X11/fonts/truetype"
  FontPath      "/usr/X11R6/lib/X11/fonts/uni:unscaled"

# ls -R /usr/X11R6/lib/X11/fonts/ | grep "/"
/usr/X11R6/lib/X11/fonts/:
/usr/X11R6/lib/X11/fonts/100dpi:
/usr/X11R6/lib/X11/fonts/75dpi:
/usr/X11R6/lib/X11/fonts/CID:
/usr/X11R6/lib/X11/fonts/Speedo:
/usr/X11R6/lib/X11/fonts/Type1:
/usr/X11R6/lib/X11/fonts/URW:
/usr/X11R6/lib/X11/fonts/encodings:
/usr/X11R6/lib/X11/fonts/encodings/large:
/usr/X11R6/lib/X11/fonts/kwintv:
/usr/X11R6/lib/X11/fonts/latin2:
/usr/X11R6/lib/X11/fonts/latin2/Type1:
/usr/X11R6/lib/X11/fonts/local:
/usr/X11R6/lib/X11/fonts/local/mma:
/usr/X11R6/lib/X11/fonts/local/mma/Type1:
/usr/X11R6/lib/X11/fonts/local/mma/X:
/usr/X11R6/lib/X11/fonts/misc:
/usr/X11R6/lib/X11/fonts/misc/sgi:
/usr/X11R6/lib/X11/fonts/truetype:
/usr/X11R6/lib/X11/fonts/uni:
/usr/X11R6/lib/X11/fonts/util:

########################################################

When I open the Mathematica Book Reference Guide in the Help Browser, I get 
a beep and the message says:

"Unable to find font with family Helvetica, weight Bold, slant Plain, and 
size 26. Substituting Courier."

Compared to the things which *were* broken, this is a minor problem.  I can 
live with the beep. What I would now like to know is how to tell Mathematica  what 
fonts to use by default.  This seemingly simple question seems to have no 
simple answer.  

Could someone please help me.

TIA,

^L


  • Prev by Date: Re: Could someone verify a long Pi calculation in Version 4 for me?
  • Next by Date: Re: Mathematica 4.1 and MacOSX 10.2
  • Previous by thread: Re: Are configuration & UI better in 4.2?
  • Next by thread: Re: Mathematica 4.1 Config:Fonts