Services & Resources / Wolfram Forums
-----
 /
MathGroup Archive
2003
*January
*February
*March
*April
*May
*June
*July
*August
*September
*October
*November
*December
*Archive Index
*Ask about this page
*Print this page
*Give us feedback
*Sign up for the Wolfram Insider

MathGroup Archive 2003

[Date Index] [Thread Index] [Author Index]

Search the Archive

Don't understand Plot behavior

  • To: mathgroup at smc.vnet.net
  • Subject: [mg39971] Don't understand Plot behavior
  • From: Alain Cochard <al2 at noos.fr>
  • Date: Thu, 13 Mar 2003 03:03:58 -0500 (EST)
  • Sender: owner-wri-mathgroup at wolfram.com

In[1]:= f[t_]:= D[t  , t] 

In[2]:= Plot[Evaluate[f[t]] , {t, 0, 1}]

Out[2]= -Graphics-    [The plot is fine]

In[3]:= Plot[{Evaluate[f[t]],0} , {t, 0, 1}]

                         -8
General::ivar: 4.16667 10   is not a valid variable.

[...]

General::stop: Further output of General::ivar
     will be suppressed during this calculation.

Plot::plnr: Evaluate[f[t]] is not a machine-size real number at t = 
              -8
    4.16667 10  .

[...]

General::stop: Further output of Plot::plnr
     will be suppressed during this calculation.

Out[3]= -Graphics- [The plot just shows the axes]

In[4]:= harhar=Evaluate[f[t]]; Plot[{harhar,0} , {t, 0, 1}]

Out[4]= -Graphics- [The plot is fine]

In[5]:= $Version

Out[5]= 4.1 for Sun Solaris (November 8, 2000)


Is this behavior normal?  Thx in advance.

Alain Cochard
al2 at noos.fr



  • Prev by Date: Re: Summations with Primes
  • Next by Date: Re: Summations with Primes
  • Previous by thread: a question about Hazard Rate
  • Next by thread: Re: Don't understand Plot behavior