Services & Resources / Wolfram Forums
-----
 /
MathGroup Archive
2004
*January
*February
*March
*April
*May
*June
*July
*August
*September
*October
*November
*December
*Archive Index
*Ask about this page
*Print this page
*Give us feedback
*Sign up for the Wolfram Insider

MathGroup Archive 2004

[Date Index] [Thread Index] [Author Index]

Search the Archive

Help -- Weird integration behavior

  • To: mathgroup at smc.vnet.net
  • Subject: [mg49345] Help -- Weird integration behavior
  • From: miked378 at hotmail.com (Mike)
  • Date: Thu, 15 Jul 2004 07:00:08 -0400 (EDT)
  • Sender: owner-wri-mathgroup at wolfram.com

I'm working on a project that I last worked on a couple of years ago,
and I'm trying to pick up where I left off. I had been doing some
integrations using Mathematica 4.2, and all was well. I'm now trying
to use the same workbook, but with Mathematica 5.0, and the
integration that previously seemed to work now gives me a value of
zero.

Interestingly, when I run the same file on different versions of
Mathematica, I get either zero or an expression:

--v5.0 (student), Macintosh: zero
--v5.0, Solaris: zero
--v4.2, Macintosh: expression
--v4.0, Windows: expression

Here's the code:
F[x_, t_] = (ks (UnitStep[x] - UnitStep[x - 0.5]))(UnitStep[t] -
UnitStep[t - 0.5]);
phi[n_, x_] = Sqrt[2] Sin[n Pi x/L]
G[n_, t_] = Integrate[F[x, t] phi[n, x], {x, 0, L}]

It's the output of this last line that's interesting to me -- either
an expression (I hope) or zero. My questions are:

-- Did something change in 5.0 that makes it so that this integration
doesn't work correctly?
-- Can anybody out there reproduce my problem (i.e., run these three
cells on different versions and produce different answers?)

Thanks for the help!


  • Prev by Date: Re: ArcCos[x] with x > 1
  • Next by Date: RE: User-defined or filled symbols for Points in ListPlots and Epilogs?
  • Previous by thread: Re: Re: importing image and getting numbers from the gray intensity
  • Next by thread: Re: Help -- Weird integration behavior