Services & Resources / Wolfram Forums
-----
 /
MathGroup Archive
2004
*January
*February
*March
*April
*May
*June
*July
*August
*September
*October
*November
*December
*Archive Index
*Ask about this page
*Print this page
*Give us feedback
*Sign up for the Wolfram Insider

MathGroup Archive 2004

[Date Index] [Thread Index] [Author Index]

Search the Archive

Re: launching a kernel on a remote linux machine through ssh from a linux machineHi,

  • To: mathgroup at smc.vnet.net
  • Subject: [mg52446] Re: [mg52381] launching a kernel on a remote linux machine through ssh from a linux machineHi,
  • From: Yasvir Tesiram <tesiramy at omrf.ouhsc.edu>
  • Date: Sat, 27 Nov 2004 01:41:00 -0500 (EST)
  • References: <200411251049.FAA21498@smc.vnet.net>
  • Sender: owner-wri-mathgroup at wolfram.com

Hi,

Just some thoughts:

Are the username the same for lamo and fast.

If different then the string passed to the shell should read

ssh username_on_fast at fast.here.com "string to launch kernel"

and use the Raw MathLink connection. In your case you don't have to
translate returns either.

And firewall settings at the other end and your end? But it sounds like
all is fine for you if you get a dialogue as you describe.


Cheers
Yas


On Thu, 25 Nov 2004 thewalterq at hotmail.com wrote:

> Greetings:
>
> I am trying to launch a kernel on a faster linux machine (call it
> "fast.here.com", IP address "5.5.5.5") and connect it to my local
> front end (on "lamo.here.com", IP address "7.7.7.7"). Both run
> Mathematica 5.0.1.0 on Fedora Linux (3 and 2, respectively). The
> connection goes through ssh.
>
> On the front end on lamo.here.com I now try to add a kernel with
> "Kernel Configuration Options...".
>
> If I select as the remote machine the same as my local machine
> "lamo.here.com", everything works fine. I know I could do this without
> going through TCP/IP, but just for checking it out:
>
>    Arguments passed to MLOpen:
>       -LinkMode Listen -LinkProtocol TCPIP
>    String passed to shell to launch kernel:
>       ssh lamo.here.com "math -mathlink -LinkMode Connect
> -LinkProtocol TCPIP -LinkName `linkname`"
>
> Choosing this to be the notebook's kernel, once I execute the first
> calculation it pops up a box saying "Link created on
> 35945 at 7.7.7.7,35946 at 7.7.7.7", then asks for the password for
> lamo.here.com, and everything works fine; I can run calculations as
> usual.
>
> The problem appears when I change the above string to
>       ssh fast.here.com "math -mathlink -LinkMode Connect
> -LinkProtocol TCPIP -LinkName `linkname`"
> (note that only the computer name has changed). When I do the first
> calculation, I still get a box saying "Link created on
> 35950 at 7.7.7.7,35951 at 7.7.7.7", then one asking for the password for
> fast.here.com. But then it stops doing anything. The result is that I
> have no kernel running, neither on fast.here.com nor on lamo.here.com,
> and no result is being displayed.
>
> Does anyone know what I'm doing wrong? I've been searching through old
> messages on this forum and could not figure it out.
>
> Thanks!
>      Walter.
>


  • Prev by Date: Re: launching a kernel on a remote linux machine through ssh from a linux machine
  • Next by Date: Re: Speeding UP Indexing and Joining ofDifferentSizeRectangular Matrixes
  • Previous by thread: Re: launching a kernel on a remote linux machine through ssh from a linux machine
  • Next by thread: Re: launching a kernel on a remote linux machine through ssh from a linux machine