Mathematica 9 is now available
Services & Resources / Wolfram Forums
-----
 /
MathGroup Archive
2005
*January
*February
*March
*April
*May
*June
*July
*August
*September
*October
*November
*December
*Archive Index
*Ask about this page
*Print this page
*Give us feedback
*Sign up for the Wolfram Insider

MathGroup Archive 2005

[Date Index] [Thread Index] [Author Index]

Search the Archive

finding roots of 1 + 6*x - 8*x^3

  • To: mathgroup at smc.vnet.net
  • Subject: [mg54630] finding roots of 1 + 6*x - 8*x^3
  • From: "Kennedy" <kennedy at oldnews.org>
  • Date: Thu, 24 Feb 2005 03:21:35 -0500 (EST)
  • Sender: owner-wri-mathgroup at wolfram.com

Hello All,

I am trying to find the roots of
1 + 6*x - 8*x^3.

Roots[1+6*x-8*x^3==0,x] yields this ugly thing:
(made uglier by my converting to InputForm)

x == ((1 + I*Sqrt[3])/2)^(1/3)/2 +
   1/(2^(2/3)*(1 + I*Sqrt[3])^(1/3)) ||
 x == -((1 - I*Sqrt[3])*((1 + I*Sqrt[3])/2)^(1/3))/4 -
   ((1 + I*Sqrt[3])/2)^(2/3)/2 ||
 x == -(1 - I*Sqrt[3])/(2*2^(2/3)*(1 + I*Sqrt[3])^
      (1/3)) - (1 + I*Sqrt[3])^(4/3)/(4*2^(1/3))

This monstrosity is chock full of imaginaries,
even though I know all three roots are real.

I tried Solve too but got the same thing, except
in the form of a set of replacements. My guess is
that Solve just calls Roots when handed a poly-
nomial.

When I ran the above through FullSimplify, I
got three "Root" objects, the upshot of which is
that the roots of the polynomial are indeed the
Roots of said polynomial. Huh.

What command can I use to get the roots into
a form that are
(a)  purely real, and
(b)  in radical form?

Thanks,
Kennedy

PS.  Mathematica 4.2


  • Prev by Date: Re: pattern matching all list elements but last
  • Next by Date: Re: problems plotting a derivative
  • Previous by thread: Re: Why are permutations duplicated with LexicographicPermutations? How to avoid this?
  • Next by thread: Re: finding roots of 1 + 6*x - 8*x^3