Mathematica 9 is now available
Services & Resources / Wolfram Forums
-----
 /
MathGroup Archive
2005
*January
*February
*March
*April
*May
*June
*July
*August
*September
*October
*November
*December
*Archive Index
*Ask about this page
*Print this page
*Give us feedback
*Sign up for the Wolfram Insider

MathGroup Archive 2005

[Date Index] [Thread Index] [Author Index]

Search the Archive

Re: Problem with loading SuperWidgetPackage

  • To: mathgroup at smc.vnet.net
  • Subject: [mg59016] Re: Problem with loading SuperWidgetPackage
  • From: David Bailey <dave at Remove_Thisdbailey.co.uk>
  • Date: Wed, 27 Jul 2005 01:24:38 -0400 (EDT)
  • References: <dc4rad$lg$1@smc.vnet.net>
  • Sender: owner-wri-mathgroup at wolfram.com

Mlatko wrote:
> [sory about this repeated test, but seems that i have problem to post
> in this newsgroup..cant see my messages.. (with other groups is ok)]
> ............
> 
> Have problems with loading SWP (Mathematica 5.0):
> 
> I  instaled SWP (extracted with WinRAR3.20) in two ways below:
>  
> 	1) C:\Program Files\Wolfram
> Research\Mathematica\5.0\AddOns\Applications\SuperWidgetPackage
> 
> 	2) C:\Documents and Settings\All Users\Application
> Data\Mathematica\Applications\SuperWidgetPackage 
> 
> 	["C:\Documents and Settings\All Users\Application
> Data\Mathematica" is my $BaseDirectory]
> 
> ..but in both cases, hapens this:
> 
> First seems to be ok after instalation and rebuliding help index,
> because "SuperWidgetPackages" appears in AddOns&links tab... 
> 
> But, when i click on "Loading the package" item in help, first i get
> this message:
> "An improperly formatted option was encountered.  The left-hand side
> of the option was not a symbol or string.", but in spite of that
> everything seems to be ok and i can read help content of "Loading the
> package"..
> 
> And when i try to evaluate: 
> 
> Needs["SuperWidgetPackage`"]
> 
> i get this two errors:
>  
> (1)Get::noopen: Cannot open GUIKit`. more...
> 
> (2)Needs::nocont: Context GUIKit` was not created when Needs was
> evaluated. more...
> 
> which obviously means that SWP didn't instaled properly..
> Earlier i instaled a few other add-ons with no problems
> and i don't know why this not work?
> 
> any help?
> thanks
> ____________
> iscekujuci dizajn: http://mapmf.pmfst.hr/~matko1/
> 
As I explained by email (did this reach you?), the primary problem here 
is that Mathematica 5.0 does not come with GUIKit - you must download it 
from the internet and install it.

The problem with the help system seems to relate to the fact that the 
UserGuide.nb file was prepared under 5.1 and seems to generate an error 
under 5.0 (although, at least in my experiments, its contents were still 
visible using 5.0).

Since there have been some serious changes in J/Link between 5.0 and 
5.1, I think I would recommend that you and any other users of the SWP 
upgrade to 5.1.

David Bailey
http://www.dbaileyconsultancy.co.uk

> 
>


  • Prev by Date: Re: Re: Setting gridlines thickness in Plot
  • Next by Date: Re: rotate frametick labels
  • Previous by thread: Re: Problem with loading SuperWidgetPackage
  • Next by thread: Re: Problem with loading SuperWidgetPackage