Mathematica 9 is now available
Services & Resources / Wolfram Forums
-----
 /
MathGroup Archive
2005
*January
*February
*March
*April
*May
*June
*July
*August
*September
*October
*November
*December
*Archive Index
*Ask about this page
*Print this page
*Give us feedback
*Sign up for the Wolfram Insider

MathGroup Archive 2005

[Date Index] [Thread Index] [Author Index]

Search the Archive

Did something change?

  • To: mathgroup at smc.vnet.net
  • Subject: [mg58109] Did something change?
  • From: Ronald Bruck <bruck at math.usc.edu>
  • Date: Sat, 18 Jun 2005 06:08:27 -0400 (EDT)
  • Sender: owner-wri-mathgroup at wolfram.com

Recently I created a list of several matrices, something like

   Do[F[i] = IdentityMatrix[8]; F[i][[1,3]] = 7, {i,10}]

and was surprised to get the message that F[i] wasn't a symbol.  I'm
pretty sure code similar to that worked prior to Mathematica 5.  Did
something change?

I've also tried Symbolize[F[i]] in that loop, but it doesn't help;
Mathematica refuses to access part [[1,3]] of F[i], claiming F[i] isn't
a symbol.

How are you supposed to set the individual values of a matrix if you
can't do this?  This is an EXTREMELY unhelpful "feature".

--Ron Bruck


  • Prev by Date: Intersection @ Complement
  • Next by Date: Re: delete something from a complex list
  • Previous by thread: Re: plot command
  • Next by thread: Re: Did something change?