Mathematica 9 is now available
Services & Resources / Wolfram Forums
-----
 /
MathGroup Archive
2005
*January
*February
*March
*April
*May
*June
*July
*August
*September
*October
*November
*December
*Archive Index
*Ask about this page
*Print this page
*Give us feedback
*Sign up for the Wolfram Insider

MathGroup Archive 2005

[Date Index] [Thread Index] [Author Index]

Search the Archive

Re: Windows version 5.1.1 font bug?

  • To: mathgroup at smc.vnet.net
  • Subject: [mg54818] Re: [mg54810] Windows version 5.1.1 font bug?
  • From: Murray Eisenberg <murray at math.umass.edu>
  • Date: Wed, 2 Mar 2005 22:29:07 -0500 (EST)
  • Organization: Mathematics & Statistics, Univ. of Mass./Amherst
  • References: <200503020627.BAA08164@smc.vnet.net>
  • Reply-to: murray at math.umass.edu
  • Sender: owner-wri-mathgroup at wolfram.com

A correction and some good (?) news....

Correction: the font problem with 5.1.1 I had was different from that 
with 5.1.  With 5.1.1, the Front End would force a quit as soon as it 
started and gave the Startup Error message.  Whereas with 5.1, the Front 
End would start, but the new symbols (e.g., the one for a Piecewise 
display) would not display.

In the case of 5.1, and possibly 5.1.1 as well, the issue would seem to 
be a problem of getting the new fonts installed when there were existing 
ones from the previous version.

The good (?) news: There's a workaround (similar to the one for 5.1): 
Delete all the Mathematica ttf fonts from Window\Fonts, then copy back 
there the ones in Mathematica5.1\SystemFiles\Fonts\TrueType.

This is only a "good (?)" news rather than "good" news because the 
workaround seemed to be necessary, whereas the Windows font issue was 
supposed to have been solved in 5.1.1.


Murray Eisenberg wrote:
> I just installed Mathematica 5.1.1 under Windows XP Pro (after 
> uninstalling 5.1).  I now have NO working version of Mathematica. 
> Perhaps some other early upgrader can help me even before Wolfram Tech 
> Support responds.
> 
> As soon as the front end opens, I get a pop-up windows titled "Startup 
> Error" with contents:
> 
>    An error has occurred while Mathematica was starting up....
>    Mathematica has detected a possible internal error. If possible
>    report the error to support at wolfram.com quoting
>    "Assertion 'b0k' failed at winFonts.c:601", and
>    describe in as much detail as possible what you were doing
>    when this error occurred.
> 
> The error first appeared when, at the end of the installation process, I 
> opted to start Mathematica in order to enter my license information.
> 
> It appeared again when I Quit and manually opened the front end from the 
> Start menu.
> 
> I tried to fix this by first deleting all the Mathematica fonts from my 
> Windows\Fonts folders, uninstalling Mathematica 5.1.1, and then 
> re-installeding it. This does not remedy the problem.
> 
> Note that trying to open forcing the Front End to open with the defaults 
> (i.e., holding down SHIFT-CONTROL during startup) does not remedy the 
> situation, either.
> 

-- 
Murray Eisenberg                     murray at math.umass.edu
Mathematics & Statistics Dept.
Lederle Graduate Research Tower      phone 413 549-1020 (H)
University of Massachusetts                413 545-2859 (W)
710 North Pleasant Street            fax   413 545-1801
Amherst, MA 01003-9305


  • Prev by Date: Re: Re: Re: Bug in Import?
  • Next by Date: Rearranging a data array containing calendrical as well as data entries.
  • Previous by thread: Windows version 5.1.1 font bug?
  • Next by thread: Re: Graphic resizing problem Linux notebook--FIXED