Services & Resources / Wolfram Forums
-----
 /
MathGroup Archive
2006
*January
*February
*March
*April
*May
*June
*July
*August
*September
*October
*November
*December
*Archive Index
*Ask about this page
*Print this page
*Give us feedback
*Sign up for the Wolfram Insider

MathGroup Archive 2006

[Date Index] [Thread Index] [Author Index]

Search the Archive

Re: 64-bit GraphPlot problem

  • To: mathgroup at smc.vnet.net
  • Subject: [mg65568] Re: [mg65547] 64-bit GraphPlot problem
  • From: János <janos.lobb at yale.edu>
  • Date: Sat, 8 Apr 2006 00:45:11 -0400 (EDT)
  • References: <200604071014.GAA02644@smc.vnet.net>
  • Sender: owner-wri-mathgroup at wolfram.com

Sorry to post to my own post, but this morning I got the following  
answer from Wolfram Support:

-----
Hello,

Thank you for the email.

Thank you for taking the time to send us this report. I have forwarded
your examples to our development group.

Unfortunately, there are no general solutions to this problem. I  appear to
be specific to Mac G5. I have included your contact information so  that you
can be notified when this has been resolved.

I am sorry for any inconvenience caused by this problem.
-----

I am now wondering what else do not work with 5.2 on a G5.

Unfortunately now I am stuck with this G5 for minimum 4 years.

I wish Wolfram send me a version - 3, 4, 5, 5.1 or whatever - non- 
expiring that does not have this problem on G5.

János


On Apr 7, 2006, at 6:14 AM, János wrote:

> Hi,
>
> I am looking the GraphPlot notebook in the Add-ons & Links ->
> Standard Packages -> DiscrateMath Help section and I am trying to
> execute the very first two lines of the notebook:
>
> In[1]:=
> << "DiscreteMath`GraphPlot`"
>
>
> In[2]:=
> GraphPlot[{1 -> 2, 2 -> 3,
>      3 -> 4, 4 -> 5, 5 -> 6,
>      6 -> 7, 7 -> 8, 8 -> 1,
>      1 -> 9, 2 -> 9, 3 -> 10,
>      4 -> 10, 6 -> 11,
>      5 -> 11, 7 -> 12,
>      8 -> 12},
>     EdgeStyleFunction ->
>      (Arrow[{#1, #2}] & )];
>  From In[2]:=
> Show[Graphics[{
> AbsoluteThickness[1],
> AbsoluteThickness[0.5],
> Line[{{190.5, 144.5}, {1.34218e+08, -1.34217e+08}}],
> Disk[
> {190.5, 144.5}, {0.25, 0.25}],
> Line[{{190.5, 144.5}, {1.34218e+08, -1.34217e+08}}],
> Disk[
> {190.5, 144.5}, {0.25, 0.25}],
> Line[{{1.34218e+08, -1.34217e+08}, {190.5, 144.5}}],
> Disk[
> {190.5, 144.5}, {0.25, 0.25}],
> Disk[
> {0, -100000}, {-100000, 0}],
> Disk[
> {190.5, 144.5}, {0.25, 0.25}],
> Disk[
> {190.5, 144.5}, {0.25, 0.25}],
> Disk[
> {190.5, 144.5}, {0.25, 0.25}],
> Disk[
> {190.5, 144.5}, {0.25, 0.25}],
> Disk[
> {190.5, 144.5}, {0.25, 0.25}],
> Disk[
> {190.5, 144.5}, {0.25, 0.25}],
> Disk[
> {190.5, 144.5}, {0.25, 0.25}],
> Disk[
> {190.5, 144.5}, {0.25, 0.25}],
> Disk[
> {190.5, 144.5}, {0.25, 0.25}],
> Disk[
> {190.5, 144.5}, {0.25, 0.25}],
> Disk[
> {190.5, 144.5}, {0.25, 0.25}],
> Disk[
> {190.5, 144.5}, {0.25, 0.25}],
> Disk[
> {190.5, 144.5}, {0.25, 0.25}],
> Disk[
> {190.5, 144.5}, {0.25, 0.25}],
> Disk[
> {190.5, 144.5}, {0.25, 0.25}],
> Disk[
> {190.5, 144.5}, {0.25, 0.25}],
> Disk[
> {190.5, 144.5}, {0.25, 0.25}],
> Line[{{190.5, 144.5}, {1.34218e+08, -1.34217e+08}}],
> Disk[
> {190.5, 144.5}, {0.25, 0.25}],
> Disk[
> {190.5, 144.5}, {0.25, 0.25}],
> Disk[
> {190.5, 144.5}, {0.25, 0.25}],
> Line[{{1.34218e+08, -1.34217e+08}, {190.5, 144.5}}],
> Disk[
> {190.5, 144.5}, {0.25, 0.25}],
> Line[{{1.34218e+08, -1.34217e+08}, {190.5, 144.5}}],
> Disk[
> {190.5, 144.5}, {0.25, 0.25}],
> AbsoluteThickness[2.25],
> Disk[
> {190.5, 144.5}, {1.125, 1.125}],
> Disk[
> {0, -100000}, {-100000, 0}],
> Disk[
> {190.5, 144.5}, {1.125, 1.125}],
> Disk[
> {190.5, 144.5}, {1.125, 1.125}],
> Disk[
> {190.5, 144.5}, {1.125, 1.125}],
> Disk[
> {190.5, 144.5}, {1.125, 1.125}],
> Disk[
> {190.5, 144.5}, {1.125, 1.125}],
> Disk[
> {0, -100000}, {-100000, 0}],
> Disk[
> {0, -100000}, {-100000, 0}],
> Disk[
> {190.5, 144.5}, {1.125, 1.125}],
> Disk[
> {190.5, 144.5}, {1.125, 1.125}],
> Disk[
> {190.5, 144.5}, {1.125, 1.125}]
> }], AspectRatio->1,
> PlotRange->{{47, 335}, {4, 292}},
> ImageSize->{288, 288}]
>
>
> The output appears to me as a straight line from the middle of the
> rectangle to the upper right corner.  I am wondering if it is just my
> machine or others can see also just a line.
>
> In[12]:=
> $Version
> Out[12]=
> "5.2 for Mac OS X (64 bit) \
> (June 20, 2005)"
>
>      Hardware Overview:
>
>        Machine Name: Power Mac G5
>        Machine Model: PowerMac11,2
>        CPU Type: PowerPC G5 (1.0)
>        Number Of CPUs: 2
>        CPU Speed: 2 GHz
>        L2 Cache (per CPU): 1 MB
>        Memory: 2 GB
>        Bus Speed: 1 GHz
>        Boot ROM Version: 5.2.7f1
>        System Version: Mac OS X Server 10.4.6 (8I116)
>
> Thanks ahead,
>
> János
> P.S.  Wolfram Support sent me another GraphPlot.m, but the result is
> the same.  /Above was done with new GraphPlot.m/.  The machine is a
> Dual Core PowerPc G5.  GraphPlot used to work perfectly on my earlier
> machine, a 1.25Ghz G4 with 32-bit Mathematica 5.1.




-------------------------------------------------------------------
János Löbb
Yale University School of Medicine
Department of Pathology
310 Cedar Street
Brady-Lauder BML50E
P.O.Box 208023
New Haven, CT 06520-8023
Phone: 203-737-5204
Fax:      203-785-7303
E-mail: janos.lobb at yale.edu


  • Prev by Date: Code problem
  • Next by Date: Re: 64-bit GraphPlot problem
  • Previous by thread: 64-bit GraphPlot problem
  • Next by thread: Re: 64-bit GraphPlot problem