Mathematica 9 is now available
Services & Resources / Wolfram Forums
-----
 /
MathGroup Archive
2006
*January
*February
*March
*April
*May
*June
*July
*August
*September
*October
*November
*December
*Archive Index
*Ask about this page
*Print this page
*Give us feedback
*Sign up for the Wolfram Insider

MathGroup Archive 2006

[Date Index] [Thread Index] [Author Index]

Search the Archive

Re: A serious error?

  • To: mathgroup at smc.vnet.net
  • Subject: [mg71903] Re: A serious error?
  • From: Andrzej Kozlowski <akoz at mimuw.edu.pl>
  • Date: Sun, 3 Dec 2006 06:26:17 -0500 (EST)
  • References: <ekrkao$s4g$1@smc.vnet.net> <457197FE.7060101@dordos.net>

Thanks a lot Peter.
Yours was the suggestion that set me on the right track! I repaired  
permissions on my hard disk and Mathematica 5.1 launched with  
problems. Indeed, it was after all font related, as I had suspected.  
Among the permissions that were wrong most were in  ./Library/Fonts.

In fact I used to know that incorrect permissions could cause such  
problems  and I frequently used this method in earlier versions of  
Mac OS X, but I have never suffered from anything in Tiger (Mac OS X  
10.4) so I assumed it somehow dealt with this sort of thing by itself.
Of course Mathematica reporting "error 16" did not help. If it told  
me that it could not access something I would have understood the  
situation at once.

Finally, I would like than everyone else who wrote to me to try to  
help. They all made good suggestions, but it required someone who had  
had a very similar experience to make the right one. Curious that  
that person turned out to be a Windows user ;-)

Thanks again Peter. Now I can again remove Mathematica 5.0 and use  
some of my favorite new functions, like Tuples ;) On down side, I  
have now lost some basis for the argument I have been making to my  
wife, that I need a new MacBook Pro ;-)

Andrzej


On 3 Dec 2006, at 00:13, Peter Pein wrote:

> Hello Andrzej,
>
> I've got the same symptoms a few days ago on my Windows 2000 PC.  
> The system
> did not go down properly, so I pressed the reset button after some ten
> minutes. Immediatelly after reboot, the screen fonts looked really  
> ugly and
> Mathematica promised to and did crash.
>
>  There have been some folders (including the one containing most of  
> the fonts)
> for which I lost the right to read/execute/write. After resetting the
> access-rights, everything worked OK.
>
> Hope that hekps a bit,
> Peter
>
> Andrzej Kozlowski schrieb:
>> I have just encountered a puzzling problem with my Mathematica 5.1
>> for Mac OS X. It's probably an issue for technical support, but just
>> in case someone has encountered it before (and known the answer) I
>> have decided to post it here. (Actually, I am not even sure this is
>> really a Mathematica issue rather than a Mac OS X issue issue).
>> My Mathematica 5.1 was working fine this morning, but then for some
>> reason I restarted the computer and on next launch the following
>> message appeared:
>>
>> A serious error has occured while Mathematica was starting up.
>> Mathematica will probably not function properly until this problem is
>> resolved. You may choose to continue anyway, but Mathematica may
>> crash or exit without warning.
>>
>> The installation Mathematica may be corrupted. Contact technical
>> support or visti hhtp://www.wolfram.com for more information. Error
>> code: 16.
>>
>> I clicked "Continue Anyway" and Mathematica crashed as promised. I
>> then immediately re-installed Mathematica from a back-up disk and re-
>> started. Exactly the same thing occured. So corrupted installation
>> does not seem to be the problem. I decided to check if the problem
>> lies in my Home directory. I created a completely new user, logged in
>> as the freshly created user and tried launching Mathematica. The same
>> message, the same crash.
>> I then booted form an external hard disk, containing a back up of
>> most things on my hard disk. I launched the copy of Mathematica 5.1
>> on my internal hard drive (the same one that was crashing on
>> startup) . It launched and worked without a problem. So, it seems
>> that something is indeed wrong with the system software on the
>> internal drive. What could it be? The only thing that came to my mind
>> was some font corruption, so I replaced all the fonts in my internal
>> hard drive by those in the external one, but to no effect.
>>
>> I have also confirmed that the problem is only with the FrontEnd; if
>> I launch the Kernel from the command line it works fine. Just in case
>> I tried Mathematica 4.2 on the same system: it also works fine.
>>
>> At the moment it looks like I will have to replace the contents of my
>> internal hard disk with my external one. This is going to be time
>> consuming and I might even loose something, because the two disks
>> have not been kept not synchronized. So I consider this as a last
>> resort. Apart of that, however, I would like to solve this puzzle.
>> What could it be, that seems to affect only the Front End of
>> Mathematica 5.1, and does not lie within the application package
>> itself (since that works fine when used with a different startup
>> disk), nor in the User directory, and does not seem to be caused by a
>> corrupted font?
>>
>> Andrzej Kozlowski
>>
>>
>


  • Prev by Date: Re: A serious error?
  • Next by Date: Re: A serious error?
  • Previous by thread: Re: A serious error?
  • Next by thread: Intercepting and Controlling Mathematica Exceptions.