Services & Resources / Wolfram Forums
-----
 /
MathGroup Archive
2006
*January
*February
*March
*April
*May
*June
*July
*August
*September
*October
*November
*December
*Archive Index
*Ask about this page
*Print this page
*Give us feedback
*Sign up for the Wolfram Insider

MathGroup Archive 2006

[Date Index] [Thread Index] [Author Index]

Search the Archive

Re: glibc version problem

  • To: mathgroup at smc.vnet.net
  • Subject: [mg72465] Re: glibc version problem
  • From: "Roman Cheplyaka" <roman.cheplyaka at gmail.com>
  • Date: Fri, 29 Dec 2006 05:35:53 -0500 (EST)
  • References: <en044a$1fg$1@smc.vnet.net>

> I've been having trouble installing Mathematica 4.2 under Linux (Ubuntu
> 6.10). It appears the problem is that I have glibc version 2.4 which is
> too new for Mathematica 4.2 to handle. I don't think I can easily
> downgrade my glibc because that will break all sorts of other software
> which is expecting version 2.4. Does anyone know what versions of glibc
> Mathematica 5.2 is compatible with? If it is compatible with glibc 2.4
> I'll probably just upgrade to Mathematica 5.2.

Mathematica does not expect to any version of glibc, neither glibc
itself. However, it's linked against libc.
I guess your problem is that Mathematica 4.2 is linked against libc5,
while glibc is providing libc6.
In this case you can safely install libc5, it must not conflict with
libc6. If Ubuntu does not ship one, you can try to borrow it from
Debian (http://packages.debian.org/stable/oldlibs/libc5).

Answering your question: yes, Mathematica 5.2 is linked against libc6.
I have glibc 2.3.6, but I believe there would not be any problem with
glibc 2.4.


  • Prev by Date: Re: large input to NMinimize causes NMinimize:"bcons" along with Less:nord ... and I don't think it should
  • Next by Date: Re: List Manipulation
  • Previous by thread: glibc version problem
  • Next by thread: Re: large input to NMinimize causes NMinimize:"bcons" along with Less:nord ... and I don't think it should