Services & Resources / Wolfram Forums
-----
 /
MathGroup Archive
2006
*January
*February
*March
*April
*May
*June
*July
*August
*September
*October
*November
*December
*Archive Index
*Ask about this page
*Print this page
*Give us feedback
*Sign up for the Wolfram Insider

MathGroup Archive 2006

[Date Index] [Thread Index] [Author Index]

Search the Archive

Re: Weird (but reproducible) screen display glitch: \[ImaginaryI] appears as just "i"

  • To: mathgroup at smc.vnet.net
  • Subject: [mg70577] Re: Weird (but reproducible) screen display glitch: \[ImaginaryI] appears as just "i"
  • From: email at email.com
  • Date: Fri, 20 Oct 2006 05:21:41 -0400 (EDT)
  • References: <eh7b04$ebo$1@smc.vnet.net>

It appears indeed as a "tiny screen font" problem. With Windows 5.2
version, increasing the zoom to 125% brings back the "ii" form. Also,
printing (I only tried PDF) gives the good "ii" form.

GL

On Thu, 19 Oct 2006 07:54:44 +0000 (UTC), AES <siegman at stanford.edu>
wrote:

>The weird behavior is that when I run the following inputs the 
>"\[ImaginaryI]" character associated with the "I (g/h^2)" in Input[2] 
>displays inside the Sqrt symbol in Output[2] as the expected Mathematica 
>"ii" symbol that looks like two lower case i's squished together under a 
>single dot -- but the same character in the same place (under the 
>radical) in Output[3] appears only as (what sure seems to be) a 
>**single** lower-case "i" -- while the "I k" terms in Input[3] display 
>with the proper \[ImaginaryI] character.
>
>In[1]:=x;Remove["Global`*"];
>
>In[2]:=f= Sqrt[1+I (g/h^2)]
>
>Out[2]=\!\(\@\(1 + \(\[ImaginaryI]\ g\)\/h\^2\)\)
>
>In[3]:=rho=(-f+I k)/(f+I k)
>
>Out[3]=\!\(\(\(-\@\(1 + \(\[ImaginaryI]\ g\)\/h\^2\)\) + \[ImaginaryI]\ 
>k\)\/\(\@\(1 \+ \(\[ImaginaryI]\ g\)\/h\^2\) + \[ImaginaryI]\ k\)\)
>
>This is at least semi-reproducible:  It remained when I copied the 
>offending lines from the place where I had first noticed it (where I was 
>using symbols other than f, g, h) and pasted them into a new notebook.  
>It remained when I re-typed the new example shown here into a fresh 
>notebook.  **It goes away if I just use "I g" instead of "I (g/h^2)" in 
>Input[2] -- and comes back when I restore the "/h^2".**  It remained 
>after shutting down Mathematica and re-opening it.
>
>Oh, and if I use the FrontEnd "Copy Output from Above" menu command just 
>below Output[3], the Input[4] that is created displays properly -- **but 
>if I execute it the Output[4] is again wrong**.
>
>A font problem of some sort, maybe?
>
>[Mathematica 5.1 on Mac iBook G4, OS 10.3.9]


  • Prev by Date: Re: Graphics/PlotRange/LaTeX/Psfrag
  • Next by Date: Re: On order of options to Graphics[]
  • Previous by thread: \( not stable during copy&paste
  • Next by thread: graphics manipulation