Mathematica 9 is now available
Services & Resources / Wolfram Forums / MathGroup Archive
-----

MathGroup Archive 2007

[Date Index] [Thread Index] [Author Index]

Search the Archive

V 6.01 Hyperlink Go Back Problem

  • To: mathgroup at smc.vnet.net
  • Subject: [mg83833] V 6.01 Hyperlink Go Back Problem
  • From: Joe Sneed <jsneed at mines.edu>
  • Date: Sun, 2 Dec 2007 04:03:44 -0500 (EST)
  • Organization: Colorado School of Mines

I run V6.01 under windows XP

The "Go Back" button on the tool bar does not appear to work, even 
though the hyperlink works/

For example, the tagged cell below appears in the .nb

tag_1
test

I use the Hyperlink [ label, URL] function as follows

Hyperlink["tag_1", {InputNotebook[ ],"tag_1"}]

which yields the button

tag_1

whose underlying code is

Cell[BoxData[
TagBox[
ButtonBox[
PaneSelectorBox[{False->"\<\"tag_1\"\>",
True->
StyleBox["\<\"tag_1\"\>",
"HyperlinkActive"]}, Dynamic[
CurrentValue["MouseOver"]],
BaselinePosition->Baseline,
FrameMargins->0,
ImageSize->Automatic],
BaseStyle->"Hyperlink",
ButtonData->{
NotebookObject[
FrontEndObject[
LinkObject["wst_shm", 1, 1]], 15],
"tag_1"},
ButtonNote->Automatic],
Annotation[#, {
NotebookObject[
FrontEndObject[
LinkObject["wst_shm", 1, 1]], 15],
"tag_1"}, "Hyperlink"]& ]], "Output",
CellChangeTimes->{3.405515715515625*^9}]

Clicking on the button carries the cursor to the appropriate cell. But, 
the the "Go Back" arrow in the tool bar does not appear activated and 
clicking it has no apprent effect.

I was able to use the "Go Back" arrow in V5.1 with no problems. 
Hyperlinks in legacy .nb's exhibit the same behavior when ren in V6.01

Any help much appreciated...

Joe

-- 
Joe Sneed
Division of Liberal Arts and International Studies
Colorado School of Mines
Golden CO USA
mailto:jsneed at mines.edu
http://www.mines.edu/fs_home/jsneed/





  • Prev by Date: Re: Exporting Sound
  • Next by Date: Re: Exporting Sound
  • Previous by thread: Re: Question with ListPlot
  • Next by thread: Re: export an array of variable depth