Mathematica 9 is now available
Services & Resources / Wolfram Forums / MathGroup Archive
-----

MathGroup Archive 2007

[Date Index] [Thread Index] [Author Index]

Search the Archive

Re: disable "disable dynamic updating?"?

  • To: mathgroup at smc.vnet.net
  • Subject: [mg84414] Re: disable "disable dynamic updating?"?
  • From: Albert Retey <awnl at arcor.net>
  • Date: Fri, 21 Dec 2007 20:44:28 -0500 (EST)
  • References: <fjqjbj$6mt$1@smc.vnet.net> <fjtbnh$5p7$1@smc.vnet.net> <fkftav$dl$1@smc.vnet.net>

Hi,

> Then it asks if I want to disable  dynamic updating or continue
> waiting.  I always hit "continue waiting", but sometimes it will just
> pop up again 10 seconds later.  Moreover this seems to interrupt the
> operation of the rest of the FrontEnd, and sometimes results in
> glitches in the formatting when it finally does complete.  I would
> really like to be able to turn this dialog off.

I think the only possibility to get rid of the dialog and the behavior 
you report is to turn off dynamics (uncheck Evaluation -> 'Dynamic 
Updating Enabled'). But this is probably not what you want, since 
obviously you are using dynamic content in your notebooks. Instead I 
would recommend to check which dynamic parts of your notebooks make this 
dialog appear and try to get rid of those.

I have encountered the problems you are describing when resizing windows 
containing deeply nested Panels which contained OpenerViews. My 
impression on this was that Mathematica didn't like that it had to 
recalculate the panel sizes (or did that in an inefficient way). So I 
don't nest Panels and OpenerViews that deep anymore and the problems are 
gone.

There might be other things that just don't work very well (yet) and 
need to be avoided. Remember that all the Dynamics-stuff is rather new 
code. Actually I am surprised how well it works overall for being all 
new in version 6...

hth,

albert


  • Prev by Date: Problem with Syntax in Mathematica Summation
  • Next by Date: Re: Updating NumberPadding?
  • Previous by thread: Re: disable "disable dynamic updating?"?
  • Next by thread: Re: disable "disable dynamic updating?"?