Mathematica 9 is now available
Services & Resources / Wolfram Forums
-----
 /
MathGroup Archive
2007
*January
*February
*March
*April
*May
*June
*July
*August
*September
*October
*Archive Index
*Ask about this page
*Print this page
*Give us feedback
*Sign up for the Wolfram Insider

MathGroup Archive 2007

[Date Index] [Thread Index] [Author Index]

Search the Archive

Re: Compatibility woes

  • To: mathgroup at smc.vnet.net
  • Subject: [mg76139] Re: Compatibility woes
  • From: Mark Adler <madler at alumni.caltech.edu>
  • Date: Wed, 16 May 2007 05:51:27 -0400 (EDT)
  • References: <f2btsp$iha$1@smc.vnet.net>

Thanks to Bhuvanesh, I got the package to load (by being explicit
about Developer` for those functions, instead of declaring it as
Needed in the BeginPackage[]).  So then I discover that Compile[] no
longer works in 6.0 the same as it did in 5.2.  I replaced it with
Function[], modifying the arguments appropriately, and the package
works, albeit slower than before.

So that's yet another thing that worked just peachy in 5.2, but no
longer works in 6.0.  I doubt that I have plumbed the depths of the
incompatibilities, since the rate of discovery is not decreasing.

Mark Adler


For the curious, the errors look like:

CompiledFunction::cfse: Compiled expression
    MarsKSAM`Private`base[MarsKSAM`Private`k][-1.05] should be a
    machine-size real number. More...

CompiledFunction::cfex: External evaluation error at instruction 87;
    proceeding with uncompiled evaluation. More...

This all worked perfectly in 5.2.



  • Prev by Date: Re: Deleting duplicates from a list
  • Next by Date: Re: weird behavior when plotting multiple functions in 6.0
  • Previous by thread: Re: Compatibility woes
  • Next by thread: Re: Re: Compatibility woes