Mathematica 9 is now available
Services & Resources / Wolfram Forums
-----
 /
MathGroup Archive
2007
*January
*February
*March
*April
*May
*June
*July
*August
*September
*October
*Archive Index
*Ask about this page
*Print this page
*Give us feedback
*Sign up for the Wolfram Insider

MathGroup Archive 2007

[Date Index] [Thread Index] [Author Index]

Search the Archive

Re: Re: Stopping Automatic Animation in v6

  • To: mathgroup at smc.vnet.net
  • Subject: [mg76949] Re: [mg76861] Re: Stopping Automatic Animation in v6
  • From: John Fultz <jfultz at wolfram.com>
  • Date: Wed, 30 May 2007 05:31:02 -0400 (EDT)
  • Reply-to: jfultz at wolfram.com

On Tue, 29 May 2007 04:49:04 -0400 (EDT), Brian Gladman wrote:
> "Szabolcs" <szhorvat at gmail.com> wrote in message
>
> news:f3dpr5$g1a$1 at smc.vnet.net...
>> Brian Gladman wrote:
>>> "Jean-Marc Gulliet" <jeanmarc.gulliet at gmail.com> wrote in message
>>> The very first time this is evaluated after starting up Mathematica,
>>> it
>>> is
>>> static but all subsequent evaluations, for example, with a change of
>>> one
>>> of
>>> the lines, are then immediately dynamic. That is, animation starts as
>>> soon
>>> as the expression is re-evaluated.  Moreover if I make a change in the
>>> expression and re-evaluate it, the graphic animation continues from
>>> the
>>> last
>>> position it reached and not from the initial position set by the
>>> expression
>>> re-evaluation.
>>>
>> What do you mean when you say "animation"? Does the plot start to *move*
>> and change by itself as soon as it appears? I don't see this behaviour
>> ... Do you have any special definitions in your init.m file? Please
>> check that $DisplayFunction is set to Identity.
>>
> I have not modified init.m manually since I installed Mathematica 6 and I
> have not changed any default settings.
>
> $DisplayFunction is set to Identity
>
>> Or do you mean the ability to rotate the graphic with the mouse? If the
>> problem is the latter, then simply set the ViewPoint option explicitly:
>> this way the view point will be reset every time you re-evaluate.
>>
> I have tried this but it does not suppress the automatic animation.
>
>> Or use PreserveImageOptions -> False.
>>
> I have not tried this explicitly but this is the default set by my init.m
> file.
>
>> You may also be interested in the RotationAction option.
>>
> I looked at this but as far as I can see it changes how the animation is
> undertaken but not whether it is undertaken.
>
>> But please try to be more specific about the problem ...
>>
> 1. Save a notebook with the expressions I gave earlier in its only two
> cells
>
> 2. Start Mathematica 6 from scratch (i.e with a completely 'clean' kernel
> and front end).
>
> 3. Load the notebook, select the two cells and select 'evaluate cells'
> from
> the evaluation menu.
>
> 4. Make no further input.
>
> On my system the graphic is produced and then it is immediately animated
> by
> showing it with a continuously changing (random?) viewpoint.
>
>>> What I am looking for is a switch to simply say that for this
>>> particular
>>> object animation should not be undertaken.
>>>
>>>> Or are you talking about the new real-time feature that allows the
>>>> user
>>>> to rotate or expand or shrink 3D graphics with the mouse?
>>>>
>>> I think it is related to this in some way. These are great new
>>> capabilities
>>> but it is not obvious to me how I can switch them on and off.
>>>
>> I really don't see why would anyone want to switch off the ability to
>> rotate graphics with the mouse ... if you don't touch them, they don't
>> change anyway ... just like in version 5.2 ...
>>
> I suspect that it is because you are not seeing the behaviour that I am
> seeing that you don't understand what it is that I want to switch off.
>
> The ability to move the graphic around with the mouse is fine and I do not
> want to switch this feature off.
>
> The 'feature' I wan't to turn off - if it is a feature and not a bug - is
> the automatic animation of the graphic after it is produced.   I must
> admit that I thought this was a feature, which is why I have been looking
> for an option to turn it off.
>
> But the fact that I am seeing this behaviour and others are not now
> suggests that it is a bug and not a feature.
>
> My thanks to you and others who have provided input on this.
>
> best regards,
>
> Brian Gladman

Brian,

My immediate suspicion is that you have a gamepad or some other USB 
HID-compatible device plugged into a USB port, and the device is not centered.  
A feature of Mathematica 6 is that you can rotate 3-dimensional graphics with a 
gamepad or joystick.  Of course, Mathematica can't tell the difference between 
an intentionally manipulated gamepad and one which just happens to not be 
centered for some other reason.

Sincerely,
 
John Fultz
jfultz at wolfram.com
User Interface Group
Wolfram Research, Inc.




  • Prev by Date: Re: Style Sheets in Version 6.0 - Again
  • Next by Date: Re: Polynomial to List
  • Previous by thread: Re: Stopping Automatic Animation in v6
  • Next by thread: .m packages "fullforms" subscripts?