Mathematica 9 is now available
Services & Resources / Wolfram Forums / MathGroup Archive
-----

MathGroup Archive 2007

[Date Index] [Thread Index] [Author Index]

Search the Archive

Re: Converting notebooks to use Mathematica Player

  • To: mathgroup at smc.vnet.net
  • Subject: [mg82768] Re: Converting notebooks to use Mathematica Player
  • From: "Steve Luttrell" <steve at _removemefirst_luttrell.org.uk>
  • Date: Tue, 30 Oct 2007 05:45:43 -0500 (EST)
  • References: <ffpq9j$lfq$1@smc.vnet.net>

I didn't get a response to my observation that your corrected version of my 
notebook runs differently in Mathematica 6 (i.e. it works OK) and 
Mathematica Player (i.e. it does not work OK). I don't yet know whether this 
is because I am trying to do something that Mathematica Player is not 
designed to do, or because I have hit upon a problem in Mathematica Player.

-- 
Steve Luttrell
West Malvern, UK

"John Fultz" <jfultz at wolfram.com> wrote in message 
news:ffpq9j$lfq$1 at smc.vnet.net...
> Mathematica Player does not evaluate Initialization cells.  You need to 
> make
> sure that any Manipulates are completely self-contained, and do not 
> require
> Shift-Enter evaluations in order to work correctly.
>
> The typical way to do this is to add SaveDefinitions->True, which will 
> suck in
> any definitions required to set up the Manipulate into the dynamic 
> evaluation
> that sets up the Manipulate output.  I took your notebook, added
> SaveDefinitions->True to the Manipulate, and ran it through the converter. 
> It
> worked fine for me.  You can find it at...
>
> http://www.wolfram.com/solutions/interactivedeployment/publish/download.jsp?id=2
> 171978932&filename=2D+Ising+Model+Fixed.nbp
>
> Sincerely,
>
> John Fultz
> jfultz at wolfram.com
> User Interface Group
> Wolfram Research, Inc.
>
>
> On Wed, 24 Oct 2007 04:28:50 -0400 (EDT), Steve Luttrell wrote:
>>
>> Mathematica 6, (2) Uploading the notebook for Mathematica Player online
>> conversion (see
>> http://www.wolfram.com/solutions/interactivedeployment/publish/), (3)
>> Posting this converted notebook online for others to access (a ZIPped
>> version is at
>> http://www.luttrell.org.uk/notebooks/2D%20Ising%20Model.zip).
>>
>> To check that things worked on a previously clean machine (i.e. without
>> Mathematica 6 installed) today I downloaded and installed Mathematica
>> Player onto an old PC (running Windows XP, but not connected to the
>> internet), and tried running the above converted notebook. The notebook
>> opens and the input cells display OK, but I can't find any way of
>> executing the notebook, despite the fact that it proudly announces
>> "interactivity enabled" at the top of the notebook, and the output of the
>> Manipulate cell appears only as a grey square. On the other hand, if I
>> try to run the converted notebook in Mathematica itself then it runs OK.
>>
>> If there is anyone else out there who has a "clean" machine (i.e.
>> Mathematica Player, but not Mathematica 6) could they see what happens
>> when
>> they try to run the converted notebook in
>> http://www.luttrell.org.uk/notebooks/2D%20Ising%20Model.zip? It is
>> important
>> that this sort of thing should work OK!
>
>
> 



  • Prev by Date: Re: wrong answer or no answer?
  • Next by Date: Re: Easy Mapping problem that has me stumped!
  • Previous by thread: Re: Re: Converting notebooks to use Mathematica Player
  • Next by thread: FullSimplify in functions