Mathematica 9 is now available
Services & Resources / Wolfram Forums / MathGroup Archive
-----

MathGroup Archive 2008

[Date Index] [Thread Index] [Author Index]

Search the Archive

Re: Constructing vector using table

  • To: mathgroup at smc.vnet.net
  • Subject: [mg91026] Re: Constructing vector using table
  • From: Jens-Peer Kuska <kuska at informatik.uni-leipzig.de>
  • Date: Mon, 4 Aug 2008 03:21:59 -0400 (EDT)
  • Organization: Uni Leipzig
  • References: <g6t0i8$3dq$1@smc.vnet.net>
  • Reply-to: kuska at informatik.uni-leipzig.de

Hi,

beside you code is not working at all, remove the MatrixForm[]
from U.

Regards
   Jens

Prateek K Jha wrote:
> I am trying to create a vector using "Table" in which I enter a
> function that depends on other functions. An excerpt from the code is:
> 
> u2[i_] := 1 + Log[\[CapitalPhi][[i]]];
> un[i_] :=
>   Switch[IntegerPart[i/(m + 1)], 0, u1n[i], 1, u2[i], 2, u2[i]];
> 
> U = Table[un[i], {i, 1, 3*m}] // MatrixForm;
> Dimensions[U]
> 
> Output:
> {1}
> 
> Everything runs fine and even the vector is generated when I see the
> form of U. But, I am not able to do any operations on this matrix
> (like inverse, transpose etc). Even the Dimensions[U] give me 1 while
> it should be 60.
> 
> Please help me through if you can. If I am not clear or you need more
> info, please let me know
> 
> Regards
> Jha
> 


  • Prev by Date: Re: Cube root of -1 and 1
  • Next by Date: Re: Recognize vector expression
  • Previous by thread: Re: Constructing vector using table
  • Next by thread: Re: Re: Constructing vector using table