Services & Resources / Wolfram Forums / MathGroup Archive
-----

MathGroup Archive 2008

[Date Index] [Thread Index] [Author Index]

Search the Archive

Re: Problems with ListPlot

  • To: mathgroup at smc.vnet.net
  • Subject: [mg6] Re: Problems with ListPlot
  • From: Igor <igorvict at gmail.com>
  • Date: Sun, 25 May 2008 02:06:14 -0400 (EDT)
  • References: <g0tqvp$mkj$1@smc.vnet.net> <g0uaj8$4vc$1@smc.vnet.net>

Sorry, PlotRange -> Full cures that. Was not evident at first.

On May 24, 11:58 am, igorv... at gmail.com wrote:
> On May 22, 2:17 pm, Szabolcs Horv=E1t <szhor... at gmail.com> wrote:
>
>
>
>
>
>
>
> > Szabolcs Horv=E1t wrote:
> > > On Tue, May 20, 2008 at 1:22 PM, dh <d... at metrohm.ch> wrote:
> > >> Szabolcs Horv=C3=A1t wrote:
>
> > >>>> 2) In addition of 1 point and 1 line (2 other should be clipped as
> > >>>> they lie outside of the range) I see 2 points, where the line cross=
es=
> > >>>> the lower and upper edges of the plot.
> > >>> I don't really understand this second question ...
>
> > >> Hi,
> > >> if you set Joined -> True, there are 2 points visible at:{1.5,0.5} an=
d
> > >> {2.5,1.5} that should not be there.
> > >> Version:"6.0 for Microsoft Windows (32-bit) (February 7, 2008)"
> > >> Daniel
>
> > > Oh, sorry, now I see what the OP meant.  The Mesh option influences
> > > this, but I couldn't find a workaround ...
> > > It would probably be quicker not to use ListPlot at all, and just
> > > build up the plot from graphics primitives (i.e. quicker than finding
> > > a workaround for this bug) ... It would also make handling plot
> > > markers easier ...
>
> > Here's a workaround:
>
> > Try moving the PlotRange option out of ListPlot (it has a different
> > meaning for plotting functions and for Graphics ... quite confusing ...)=
:
>
> > Show[
> >   ListPlot[{0, 1, 2},
> >    PlotMarkers -> Style["\[FilledCircle]", FontSize -> 12],
> >    Joined -> True, GridLines -> Automatic],
> >   PlotRange -> {{1, 3}, {0.5, 1.5}}, AxesOrigin -> Automatic]- Hide qu=
ot=
> ed text -
>
> > - Show quoted text -
>
> O.K. Now I see that I need to use Show for PlotRange to work as
> expected...
>
> Though these are not the only problems with ListPlot.
> Try to run the following code:
>
> ListPlot[{{0, 0}, {1, 1}, {1, 2}, {1, 5}, {2, 2}, {2, 1}},
>  Joined -> True]
>
> Automatic PlotRange definition seems to be very buggy. Most of the
> graphic is not shown!- Hide quoted text -
>
> - Show quoted text -



  • Prev by Date: Re: Sluggish performance in Save, bug?
  • Next by Date: Re: Re: Problems with ListPlot
  • Previous by thread: Re: Problems with ListPlot
  • Next by thread: Re: Re: Problems with ListPlot