Mathematica 9 is now available
Services & Resources / Wolfram Forums / MathGroup Archive
-----

MathGroup Archive 2009

[Date Index] [Thread Index] [Author Index]

Search the Archive

Re: 3D plots and using mouse click-drag to rotate - why the extra

  • To: mathgroup at smc.vnet.net
  • Subject: [mg98803] Re: 3D plots and using mouse click-drag to rotate - why the extra
  • From: "Sjoerd C. de Vries" <sjoerd.c.devries at gmail.com>
  • Date: Mon, 20 Apr 2009 01:28:16 -0400 (EDT)
  • References: <gseoo2$eag$1@smc.vnet.net>

Bob,

After a rotation Mathematica tries to fit a frame as good as possible
around the plot. This is what causes the jump. If you add
SphericalRegion -> True to your Plot function Mathematica reserves
enough blank space so that the frame will always be able to contain
the plot however you rotate it.

If you scale there is no extra fitting necessary, so no jump.

Cheers -- Sjoerd

On Apr 19, 10:52 am, Bob F <deepyog... at gmail.com> wrote:
> When you create a 3D plot and then use the mouse to click-drag to
> rotate the surface to view it from another angle, there is always an
> extra translation thrown in by Mathematica as soon as you let the
> mouse button go after this click-drag. However, if you do an Option-
> click to zoom in or out and then let go there is no extra translation,
> and thereafter if you click-drag as before there is no extra
> translation after letting go of the mouse button. Is this extra
> translation at the end something that you can prevent without having
> to resort to the Option-click/zoom step?? I am on a Mac with version
> 7.0.1 (I think this has occured for a long time, but can't verify it
> right now). So for example if you try something like:
>
> Plot3D[Sin[x y] + 10, {x, -3, 3}, {y, -3, 3},
>  AxesOrigin -> {0, 0, 10}, Boxed -> False,
>  PlotRange -> {Automatic, Automatic, {0, 20}}]
>
> and then click-drag to rotate to look at the bottom and let go there
> is an extra little jump that the surface goes thru when you let the
> mouse button go. Then do an Option-click and zoom in and out to still
> maintain the entire surface in view and let go and no extra jump
> either. Now do a click-drag again and let go and no extra little
> translation any more (until you re-execute the cell again).
>
> Comments?
>
> -Bob



  • Prev by Date: Re: 3D plots and using mouse click-drag to rotate - why the extra
  • Next by Date: Re: Strange Output!!!Please help me thank you.
  • Previous by thread: Re: 3D plots and using mouse click-drag to rotate - why the extra
  • Next by thread: Rearranging & Restructuring Lists: Changing pattern order in