Mathematica 9 is now available
Services & Resources / Wolfram Forums / MathGroup Archive
-----

MathGroup Archive 2009

[Date Index] [Thread Index] [Author Index]

Search the Archive

Re: Re: Reading csv with ;

  • To: mathgroup at smc.vnet.net
  • Subject: [mg99517] Re: [mg99493] Re: Reading csv with ;
  • From: George Woodrow III <georgevw3 at mac.com>
  • Date: Thu, 7 May 2009 06:34:01 -0400 (EDT)
  • References: <gtp1h5$k58$1@smc.vnet.net> <200905060929.FAA02205@smc.vnet.net>

"magic word is right".

I knew that there was an option for field separators, and it took me a 
while to track it down.

In version 5.2, the option WAS "FieldSeparator" (no final 's'), but 
the option was listed on the documentation page for Export, so someone 
might have a chance to find it if they didn't already know about it. 
(It might have been good to have the option listed on the Import doc 
page, but I don't think it is there in 5.2.)

In version 7, the option appears only on the page for Table, and then 
only in the examples. At least that is what a search in the 
Documentation Center gives. Also it is the only place that a Google 
search gives for the on-line version of the Version 7 documentation. 
Spotlight does not find anything in Mathematica -- perhaps the plug-in 
is broken.

This is another example of the problem with Mathematica Documentation. 

It's not going to be fixed with PDFs or even a physical book.

It's too hard to find things without knowing about them in the first 
place. The information (most of it, anyway) is there, but it is not 
arranged to be accessible by non-experts quickly.

george woodrow


On May 6, 2009, at 5:29 AM, dh wrote:

>
>
> Hi Dennis,
>
> assume we have a file:
>
> 1;2
>
> 3;4
>
> we can read this by e.g.:
>
>
>
> Import["d:/tmp/t.txt", "Table", "FieldSeparators" -> {";"}]
>
>
>
> The magic word is "FieldSeparators".
>
> Daniel
>
>
>
> Dennis wrote:
>
>> I'm trying to read a csv with mathematica
>
>>
>
>> Now the problem is that my system settings are at ";" as seperator 
>> instead of more traditional ",". So the it effectively looks like 
>> 1;1;1;1 instead of 1,1,1,1
>
>>
>
>> Normally this makes not difference as in most software you can 
>> choose the delimiter/seperator before reading a file, so you pick 
>> =93separator = ;=94 or whatever.
>
>>
>
>> With mathematica however I have so far been unable to do this. Now =

>> the question of course: how so I change the seperator with 
>> mathematica?
>
>>
>
>> Because quite a few files have a =93;=94 separator I would like to =
find 
>> a solution within mathematica instead of changing the system 
>> settings.
>
>>
>
>> Cheers,
>
>>
>
>> Dennis
>
>>
>
>
>



  • Prev by Date: Re: Picking Off Lists That Have No Numbers
  • Next by Date: Re: Picking Off Lists That Have No Numbers
  • Previous by thread: Re: Reading csv with ;
  • Next by thread: Re: Re: Reading csv with ;