Mathematica 9 is now available
Services & Resources / Wolfram Forums / MathGroup Archive
-----

MathGroup Archive 2009

[Date Index] [Thread Index] [Author Index]

Search the Archive

Text cell formating blues. LineBreakWithin, PageWidth, WordWrapping

  • To: mathgroup at smc.vnet.net
  • Subject: [mg104084] Text cell formating blues. LineBreakWithin, PageWidth, WordWrapping
  • From: "Nasser M. Abbasi" <nma at 12000.org>
  • Date: Sun, 18 Oct 2009 05:24:40 -0400 (EDT)
  • Reply-to: "Nasser M. Abbasi" <nma at 12000.org>

Hello

V7 on windows XP.

I normally use Mathematica just to do the computation/solving/verification 
part and then use Latex for actually writing my final homework and school 
report (I use Scientific workplace SW).

Today I decided to give Mathematica another try to see if I can write the 
whole thing in one document, i.e. code and report. This way everything is in 
one place and no need to copy and paste stuff between Mathematica and SW.

For the last hour and more I have been fighting with Mathematica to make 
Text cells look nice after exporting to PDF. i.e. i'd like lines to be of 
reasonably equal length.

Mathematica break lines in places where I do not want it to, so I end up 
with text paragraphs that looks like the following on the screen and also in 
PDF (notice the extra spaces even to the left of some lines)

xxxxxx
  xx,
 xxxxx
   xxxxxxxxx,
xxxx

So, this is what I tried, but I am about to give up, but I thought let me 
post this and may be there is simple solution that I am missing.

First I turned OFF the LineBreakWithin (i.e. set it to false from automatic 
in the option inspector, did this for Global, Notebook and Selection). btw, 
why does an "X" still show up sometime the the left of an option name after 
I change its value?

So, now my lines are very long and they are cut off when printing. I.e. they 
are like this

xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx

So, I select the text cell again, and did Format->WordWrapping->Wrap at 
paper width, but now it looks like

xxxxxxx| text here not showing
xxxxxxx| ......
xxxxxxx| .....
xxxxxxx| .....

and the rest of each line (if it longer than page width) is not visible on 
the screen and neither in PDF.

Next I went to option inspector and set "PageWidth" to paperWidth (it was 
infinity) I could only change this option in Global and not in notebook or 
Selection (the field was grayed out there). ?

But this did not help either. For lines that are too long, I can see the 
rest of the line on the screen and have to scroll horizontally to see it.

I tried many other things.

Does any one know what is the best combination of options/formatting to use 
so that text cells would looks the best for printing?  and which font to use 
for best results?

btw, I try to not hit carriage return when I write text in a text cell. 
Turning off LineBreakWithin seems to be the key option to play with, but I 
think I made things worst.

I tried also to change the cell style  to ItemParagraph from text, but this 
did not seem to help much.

I would love to use Mathematica to typeset my reports, but I still find 
Latex output via SW easier to work with.

ps. I use Report style sheet, but even default style sheet has the same 
problem.

I put the current notebook here that I am trying these things on, so you can 
see the mess I made with the text cells

http://12000.org/tmp/oct_16_2009/

thanks for any hints

--Nasser










  • Prev by Date: Text cell formating blues. LineBreakWithin, PageWidth, WordWrapping
  • Next by Date: Re: ChemicalData[], SMILES, EdgeRules
  • Previous by thread: Text cell formating blues. LineBreakWithin, PageWidth, WordWrapping
  • Next by thread: Re: Text cell formating blues. LineBreakWithin, PageWidth, WordWrapping