Services & Resources / Wolfram Forums / MathGroup Archive
-----

MathGroup Archive 2010

[Date Index] [Thread Index] [Author Index]

Search the Archive

Re: DSolve difficulties ...

  • To: mathgroup at smc.vnet.net
  • Subject: [mg111843] Re: DSolve difficulties ...
  • From: Helen Read <hpr at together.net>
  • Date: Sun, 15 Aug 2010 07:36:46 -0400 (EDT)
  • References: <i45rdj$g3o$1@smc.vnet.net>

On 8/14/2010 6:33 AM, Slide wrote:
> Yesterday I typed in the following command line, into the student
> version of Mathmatica .
>
> DSolve[y''[x] == 1/(y[x]*y[x]), y[x], x]
>
> and got a complicated Solve command and expression back with the
> comment 'The equations appear to involve the variables to be solved
> for in an essentially non-algebraic way.'

Adding to my previous post:

OK, the solution to DSolve comes out like this:

Solve[((1/(C[1]^(3/2)))
     Log[-2 + 2 (C[1] + Sqrt[C[1]] Sqrt[C[1] - 2/y[x]]) y[x]] + (
     Sqrt[C[1] - 2/y[x]] y[x])/C[1])^2 == (x + C[2])^2, y[x]]

That is, Mathematica is able to solve the differential equation, but the 
solution is given implicitly, rather than solved for y[x]. It got to the 
part where it wants to solve for y[x] in terms of x, can't do it, and 
quits there.

If you then evaluate the output (the Solve[ ] ), you will get the 
message about "essentially non-algebraic" which is Mathematica's way of 
saying it cannot solve the equation explicitly. (It would have to begin 
with, if it could.)

-- 
Helen Read
University of Vermont


  • Prev by Date: Re: Creating a simple state inspector for Mathematica
  • Next by Date: Re: Problem using LinkSnooper when Mathematica pathname contains a space
  • Previous by thread: Re: DSolve difficulties ...
  • Next by thread: Re: DSolve difficulties ...