Services & Resources / Wolfram Forums / MathGroup Archive
-----

MathGroup Archive 2010

[Date Index] [Thread Index] [Author Index]

Search the Archive

Re: Manipulate and ParametricPlot Control?

  • To: mathgroup at smc.vnet.net
  • Subject: [mg114362] Re: Manipulate and ParametricPlot Control?
  • From: John Fultz <jfultz at wolfram.com>
  • Date: Thu, 2 Dec 2010 05:39:12 -0500 (EST)

It almost certainly was a typo on your part.  Here's one possible way you might
have made the typo that produces this result:

Manipulate[Plot[x^a, {x, 0, 1}], {a, {0, 1}, 5}]

If you try this instead...

Manipulate[a, {a, {0, 1}, 5}]

...you can see how 'a' is being manipulated.

Then Power[] threaded through the list as so...

In[19]:== x^{1, 1}

Out[19]== {x, x}

and Plot[] does exactly what it's documented to do with lists.

There aren't any bugs in this behavior, although this specific Manipulate syntax
is not AFAIK documented...but it's an obvious shortcut from one which is
documented.

Sincerely,

John Fultz
jfultz at wolfram.com
User Interface Group
Wolfram Research, Inc.


On Wed, 1 Dec 2010 02:11:32 -0500 (EST), AES wrote:
> This is a "what did I do wrong" post?  It's related to the
> "re-virginating" thread I started recently, but quite separate (and I
> think genuinely puzzling).
>
> As a simple test file, I created a notebook (which I don't have any
> more) containing the one cell
>
> Manipulate[ Plot[x^a, {x,0,1}], {a,0,5}]
>
> (May have had a PlotRange option also; don't recall for sure.)
>
> Executed it; worked as expected.
>
> Decided to set an initial value for a; as best I recall (details are
> fuzzy), I edited the cell to change {a,0,5} to {{a,1},0,5}  (that's what
> I intended to do, anyway).
>
> When I re-executed the cell, I got a live Manipulate that displayed a
> ***two-dimensional*** (2D) Control -- something I had never seen before,
> but which looked exactly like the one I more recently found in the
> ParametricPlot example in the Manipulate Help.
>
> Exercising this Manipulate displayed **two** x^a curves, with values
> corresponding to the H and V axes of the 2D Control.  Functioned fine;
> no error msgs at any time.
>
> I made a (presumably erroneous) guess that the edited cell must have
> somehow been influenced by the earlier execution of the initial,
> un-edited version of the same cell (I had two implementations of the "a"
> variable floating around, maybe??).  So, I tried adding Removes before
> the cell; tried Saving it, Quiting Mathematica, and re-opening it.  The 2D
> Control obstinately remained (and worked).  This then led to the
> re-virginating query.
>
> I may have made a typo in the editing I noted above, but I sure as hell
> did NOT change Plot to ParametricPlot.  And when I try some tests now
> using Plot[ {f1, f2}, ...] inside a Manipulate, I get two curves -- but
> never a 2D Control.
>
> Any ideas what went wrong here?



  • Prev by Date: Re: How to bring up specific doc page programmatically?
  • Next by Date: Re: How to bring up specific doc page programmatically?
  • Previous by thread: Re: Manipulate and ParametricPlot Control?
  • Next by thread: Re: Why ParallelTable does not use CUDA