Mathematica 9 is now available
Services & Resources / Wolfram Forums / MathGroup Archive
-----

MathGroup Archive 2010

[Date Index] [Thread Index] [Author Index]

Search the Archive

Re: need help with CUDA setup on my MacBook Pro

  • To: mathgroup at smc.vnet.net
  • Subject: [mg114920] Re: need help with CUDA setup on my MacBook Pro
  • From: Stefan Wolfrum <metawops at gmail.com>
  • Date: Thu, 23 Dec 2010 03:51:34 -0500 (EST)
  • References: <iehef5$av7$1@smc.vnet.net> <ieklp8$4v3$1@smc.vnet.net>

Hi Patrick,

no I didn't try to compile & start the examples. I just downloaded the
CUDA driver from Nvidia & didn't get any examples.
I downgraded the driver to 3.1.17 now (used to have 3.2.17, the latest
from Nvidia for the 9600M GT).

However, still the same: CUDAResourcesInstall[] immediately gives a
$Failed as result and I can't manage to get the CUDA resources
installed manually:

In[7]:=
CUDAResourcesInstall["/Users/stefan/Downloads/CUDAResources-OSX-8.0.0.6.p=
aclet"]
During

evaluation of In[7]:= Message::name: Message name CUDAResources paclet
path `1` is not valid. is not of the form symbol::name or
symbol::name::language. >>
Out[7]= $Failed

As mentioned I just renamed the downloaded file, which came in as
..paclet.zip to .paclet .

Still clueless,
Stefan.


On 2010-12-19 11:11:52 +0100, Patrick Scheibe said:

> Hi,
>
> did you try to compile and start the examples which come with CUDA?
> Which version of the CUDA Toolkit do you use? If you're using 3.2,
> please use 3.1.
>
> Cheers
> Patrick
>
> On Fri, 2010-12-17 at 23:48 -0500, Stefan Wolfrum wrote:
>> Hi all,
>>
>> my MacBook Pro (MBP) is running OS X 10.6.5 and Mathematica Home
>> Edition 8.0.0.0 (32bit).
>> It's a MBP with two graphics chips: an Nvidia GeForce 9400M and a 9600=
M
>> GT -- the latter one is listed as a support chipset for Mathematica's
>> CUDA functionality. I activated the 9600M GT chip and verified that
>> it's the currently used one.
>> I, too, downloaded and installed Nvidia's CUDA driver.
>> However, I still get "False" from the CUDAQ[] query.
>> I thought that's because of the missing CUDA Ressources so I tried
>>
>> In[17]:= CUDAResourcesInstall[]
>>
>> but I immediately got
>>
>> Out[17]= $Failed
>>
>> Mathematica never even tried to download that from it's paclet server
>> -- despite the fact that I allowed Mathematica to access the Internet
>> in the settings.
>>
>> So I downloaded the paclet manually (which worked).
>>
>> However, on a Mac, the downloaded file ends in .zip:
>> CUDAResources-OSX-8.0.0.6.paclet.zip
>>
>> Now I tried several different variations of the path to this paclet in
>> the CUDAResourcesInstall command:
>> - gave it the full path including the zip filename
>> - unpacked the zip file, got a folder "CUDAResources-OSX-8.0.0.6"
>> (without the ".paclet"), and used the path to this folder
>> - just removed the ".zip" suffix from the downloaded file and gave
>> CUDAResources-OSX-8.0.0.6.paclet as parameter
>>
>> .... but none worked. :-(
>>
>> The "best" I got (with the last variation mentioned above) was this:
>>
>> In[14]:=
>> CUDAResourcesInstall["/Users/stefan/Downloads/CUDAResources-OSX-8.0.0.=
6.p=
>> aclet"]=E2=80=A8
>>
>> Message::name :  "Message name "CUDAResources paclet path
>> `1` is not valid." is not of the form symbol::name or
>> symbol::name::language.
>> Out[14]= $Failed
>>
>> Any help on how I can install this paclet?
>> And why doesn't the normal (automatic) installation via
>> CUDAResourcesInstall[] work???
>>
>> Thanks a lot!
>> Stefan.



  • Prev by Date: Re: switching between versions 7 and 8
  • Next by Date: Re:: Reduce in Mathematica 5 vs Mathematica 8
  • Previous by thread: Re: need help with CUDA setup on my MacBook Pro
  • Next by thread: Query available max memory (RAM)?