Services & Resources / Wolfram Forums / MathGroup Archive
-----

MathGroup Archive 2010

[Date Index] [Thread Index] [Author Index]

Search the Archive

Re: Sizing opening window in Mathematica 8

  • To: mathgroup at smc.vnet.net
  • Subject: [mg114109] Re: Sizing opening window in Mathematica 8
  • From: WetBlanket <wyvern864 at gmail.com>
  • Date: Tue, 23 Nov 2010 06:03:38 -0500 (EST)
  • References: <ic5ifl$43n$1@smc.vnet.net> <icdo7l$6cv$1@smc.vnet.net>

On Nov 22, 6:38 am, "Rolf.Mer... at gmail.com" <rolf.mer... at gmail.com>
wrote:
> Harvey,
> one possibility is:
>
> If[$Linked,  (* do nothing for kernel-only sessions *)
>    RunScheduledTask[
>      FrontEndExecute[{
>      SetOptions[FrontEnd`InputNotebook[], WindowSize -> {1150,750}]=
,
>      SetOptions[FrontEnd`InputNotebook[], WindowMargins ->
> {{7,Automatic},{Automatic,6}}]}], {0.4, 7}];
>
> ];
>
> Depending on your hardware you can tweak the {0.4, 7} numbers.
>
> In case you want to get rid of the ScheduledTask object, add:
> RunScheduledTask[RemoveScheduledTask[ScheduledTasks[]], {5, 1}]
>
> --
> Dr. Rolf Mertig
> GluonVision GmbH, Berlin, Germanyhttp://www.gluonvision.com
>
> On Nov 19, 11:11 am, "Harvey P. Dale" <h... at nyu.edu> wrote:
>
> > In Mathematica 7, I was able to put the following commands into
> > the proper init.m file and, as a result, have the first default window
> > open with the size and location that I prefer:
>
> > FrontEndExecute[{SetOptions[FrontEnd`InputNotebook[],WindowSize->{1150,=
7
> > 50}],
> > SetOptions[FrontEnd`InputNotebook[],WindowMargins->{{7,Automatic},{Auto=
m
> > atic,6}}]}]
>
> > This does not seem to work, however, in Mathematica 8.  How can I
> > achieve the same result in Mathematica 8?
>
> > Thanks.
>
> > Harvey P. Dale
>
> > ______________________________________________________________________
> > This email has been scanned by the MessageLabs Email Security System.
> > For more information please visithttp://www.messagelabs.com/email
> > ______________________________________________________________________

Why can't this be specified in the Option Inspector?  I have tried but
cannot seem to get it to work.  Also, using he Preference screen that
one gets from the Edit dropdown I have set my comments to display in
Orange.  However, this does not seem to work either.  Anyone have any
ideas why using the option inspector and the Preferences does not seem
to effect the notebooks?


  • Prev by Date: Re: Mathematica 8: first impressions
  • Next by Date: Re: Mathematica 8
  • Previous by thread: Re: Sizing opening window in Mathematica 8
  • Next by thread: How to specify "arbitrary depth" for a (sub)pattern?