Mathematica 9 is now available
Services & Resources / Wolfram Forums / MathGroup Archive
-----

MathGroup Archive 2010

[Date Index] [Thread Index] [Author Index]

Search the Archive

Mathlink Issue

  • To: mathgroup at smc.vnet.net
  • Subject: [mg113422] Mathlink Issue
  • From: Andrew Newell <a.newell at ucl.ac.uk>
  • Date: Thu, 28 Oct 2010 04:26:06 -0400 (EDT)

Dear All,

I have some code that I have been using successfully for a while which  
installs a Mathlink program using the lines:

SetDirectory["MathLink/oBIF2"];
link=Install["doone"];

Recently, I've been trying to sort out another Mathlink issue for a  
different task. I'm not aware of having changed any settings, but when  
I run the above code I now get the error:

LinkOpen::linke: Error 19 >>

The Mathematica help implies this error is to do with LinkMode and  
LinkProtocol settings, but when I specify these manually using:

link = Install["doone", LinkMode -> Launch, LinkProtocol ->  
"SharedMemory"];

I get the same error.

The file 'doone' is a valid Mathlink program and it works fine on  
other machines running the same operating system (Mac OS X 10.5.8).  
I've also tried other valid Mathlink programs and they all produce the  
same error.  I'm using Mathematica 7.0.1 and I've tried reinstalling  
it but the error still occurs. I've also tried using Mathematica 6.0.0  
and I get the same error.

This would seem to imply that the problem is not with the Mathematica  
installation or with the Mathlink program 'doone', but with some  
setting that is stored elsewhere.

Any help much appreciated,

Andrew



  • Prev by Date: Re: More Mathematica CAN'T do than CAN???
  • Next by Date: Re: Table for 3D points
  • Previous by thread: ListPlot3D[] - rather slow?
  • Next by thread: solving an integral