Mathematica 9 is now available
Services & Resources / Wolfram Forums / MathGroup Archive
-----

MathGroup Archive 2012

[Date Index] [Thread Index] [Author Index]

Search the Archive

Re: irritating screen jumps in Mathematica 8.0.4

  • To: mathgroup at smc.vnet.net
  • Subject: [mg125313] Re: irritating screen jumps in Mathematica 8.0.4
  • From: JUN <noeckel at gmail.com>
  • Date: Tue, 6 Mar 2012 05:57:24 -0500 (EST)
  • Delivered-to: l-mathgroup@mail-archive0.wolfram.com
  • References: <jit120$e7p$1@smc.vnet.net> <jivd38$n73$1@smc.vnet.net>

On Sunday, March 4, 2012 1:36:40 AM UTC-8, JUN wrote:
> On Saturday, March 3, 2012 3:58:56 AM UTC-8, Dushan Mitrovich wrote:
> > Using Mathematica 8.0.4 under Mac OS X.6.8 I finally got irritated
> > enough by a certain behavior to ask here if there's any way to stop it.
> >
> > A lot of the typical notebook I work on involves word processing, with
> > only occasional Input/Output cells as needed.  So most of the equations
> > are in separate lines and contained in math boxes (enclosed by Ctrl-(
> > and Ctrl-) ).
> >
> > If I edit something in one of those boxes, then hit either Up-arrow or
> > Down-arrow to get out of it and go to the previous or next line, the
> > cursor jumps to the front or back of the box and all the screen contents
> > jump _down_.  So going into and out of a math box by repeating either
> > arrow key combination {Left, Down} or {Right, Up} will cause the screen
> > contents to keep jumping down until the box is at the bottom of the
> > screen.  At that point the Left or Right arrow key causes the screen
> > contents to jump up so the box is inside the window, then the Down or Up
> > keys jumps it back to where it was.
> >
> > The jumps (of the screen contents, not of the cursor) almost guarantee
> > that I'll momentarily lose my place and have to re-find it.  This is the
> > irritant, and I see no reason why it should exist.  The cursor jumping
> > into and out of the box would be no problem, as it wouldn't destroy
> > one's focus.
> >
> > Have others run into this, and if so is there a way to prevent it?
> >
> > - Dushan
>
> This also happens on Mac OS 10.7.3, and it's been one of the reasons why I don't usually write long texts with maths in Mathematica (combined with other problems such as inadequate undo functionality).
>
> I don't know how to fix this for equations in text cells, but at least the jumps don't occur if you put equations in DisplayFormula or DisplayFormulaNumbered cells (this can be chosen from the Format > Style menu), instead of text cells. I would try to do that as much as possible, but of course sometimes you need inline maths as well, and in that case the only way to avoid screen jumps is to emulate the math style by hand, e.g. by choosing italic font for variables without putting them in a Ctrl-( inset. This of course can't always be done.
>
> Jens

Just to add some more shortcut information:

After you have inserted your first displayed formula, you can get back to the same style directly by pressing command-0. This brings up the style menu with the last setting selected. Then you simply press return to get a new cell with that style, press Shift-Command-t to enter TraditionalForm. Now you're ready to start entering the formula not perfect, but at least some shortcuts do exist.

Jens



  • Prev by Date: problems with Rasterize
  • Next by Date: Re: Engineering requests
  • Previous by thread: Re: irritating screen jumps in Mathematica 8.0.4
  • Next by thread: Re: irritating screen jumps in Mathematica 8.0.4