Services & Resources / Wolfram Forums / MathGroup Archive
-----

MathGroup Archive 2013

[Date Index] [Thread Index] [Author Index]

Search the Archive

Mathematica does not recognize C Compiler

  • To: mathgroup at smc.vnet.net
  • Subject: [mg131377] Mathematica does not recognize C Compiler
  • From: Joao <joaopereira9 at gmail.com>
  • Date: Tue, 16 Jul 2013 05:57:25 -0400 (EDT)
  • Delivered-to: l-mathgroup@mail-archive0.wolfram.com
  • Delivered-to: l-mathgroup@wolfram.com
  • Delivered-to: mathgroup-outx@smc.vnet.net
  • Delivered-to: mathgroup-newsendx@smc.vnet.net

Hi, I would like to ask for some help regarding C Compilers in Mathematica.
 
The problem I have is that Mathematica does not recognize the presence of a C Compiler.

When I do CCompilers[Full] it returns:

{{Name->Intel Compiler,Compiler->CCompilerDriver`IntelCompiler`IntelCompiler,CompilerInstallation->None,CompilerName->Automatic},{Name->Generic C Compiler,Compiler->GenericCCompiler,CompilerInstallation->None,CompilerName->Automatic}}

And when I do CCompilers[ ] it returns { }

Also, 

DefaultCCompiler[]

NVCCCompiler

I have Windows 7 Ultimate 64 bits.

I followed this thread:
http://mathematica.stackexchange.com/questions/5487/how-do-i-get-mathematica-to-recognize-a-c-compiler-on-a-64-bit-windows-machine

and installed two C Compilers:  one via .NETFramework and Windows SDK 7.1, the other one was the 64 bit MinGW.
Unfortunetely Mathematica 8 still does not recognize any C Compiler. 

I tried 
$CCompiler = {"Compiler" -> GenericCCompiler, 
   "CompilerInstallation" -> "C:��Path", 
   "CompilerName" -> "x86_64-w64-mingw32-gcc.exe"};

After this i tried CCompiler[ ] and the output was:

{"Compiler" -> GenericCCompiler, 
   "CompilerInstallation" -> "C:��Path", 
   "CompilerName" -> "x86_64-w64-mingw32-gcc.exe"}

Nevertheless, when I do CCompiler [ ] the result shows nothing again.

Regarding the Microsoft CCompiler, Iâ??m not sure what executable file is appropriate, I read somewhere that it should be cl.exe but I canâ??t find this file anywhere. As you can see I am not very familiar with this subject.

Could you let me know what I am doing wrong here?

I really need to speed up some code.

Thanks in advance

Joao



  • Prev by Date: Re: An analytical solution to an integral not currently in
  • Next by Date: reduce needs too much memory
  • Previous by thread: Re: An analytical solution to an integral not currently in
  • Next by thread: Re: Mathematica does not recognize C Compiler