Mathematica 9 is now available
Student Support Forum
-----
Student Support Forum: 'Linux front-end woes' topicStudent Support Forum > General > Archives > "Linux front-end woes"

Next Comment >Help | Reply To Topic
Author Comment/Response
Aaron King
01/20/99 04:53am

I've got a strange phenomenon maybe you can help me to understand.
I'm running Mathematica on the latest version of RedHat linux at home.
When I use the gui front end, it puts up various subsidiary windows
(''Palettes''). When I run Mathematica as root, no problems. But when
I run it as a mere user, these subsidiary windows appear without the
ordinary motif frame, i.e., without buttons to make it go away, and
with no possibility of moving the window. I figured that the problem
might be with the permissions, so I made sure everything in /usr/X11R6
is readable and/or executable to everyone, and I fiddled with the
paths, to no avail. What is going on here?

Another question: I've noticed that Mathematica takes an inordinately
long time to start up its front end, and to establish a link between
front end and kernel. This is a 450 MHz machine, and I can think of
no reason why it should take 1-2 min to establish such a connection,
can you? The problem is the same when I'm running the kernel alone
out of a shell. Here, the kernel starts up right away, but the first
time I try to plot something, it takes 1-2 min to put up a graphics
window. After the first one, everything is pretty much instantaneous.
Any thoughts on this?

URL: ,

Subject (listing for 'Linux front-end woes')
Author Date Posted
Linux front-end woes Aaron King 01/20/99 04:53am
Re: Linux front-end woes Levi Kennedy 02/04/99 05:09am
Next Comment >Help | Reply To Topic