Mathematica 9 is now available
Student Support Forum
Student Support Forum: 'Re: AltGr-Key' topicStudent Support Forum > General > Archives > "Re: AltGr-Key"

Help | Reply To Topic
Author Comment/Response
Rustam-Robert Ghadially
05/11/97 06:59am

Reply to message #331 from Matthias Soehn: > Reply to message #216
from Helmut Podhaisky: > > > > I can't type any key in ''[]{}\'' in
the FrontEnd, > > but copy+paste works. > > In the X-Environment-Info-Menu
the keys works. > > > > My Environment: Linux (S.u.S.E Distribution)
2.0 > > Mathematica Version 3.0.0 > > > > Keyboard: german,i.e. [
is <AltGr> 8 > > > > Indeed what Friehelm proposes works --- but only
when the ''pureKeys''-option is disabled. However, surely I'm not
the only user who needs this option for proper work of all keys. >
> ''Brackets.nb'' also works, of course (although ''@ <=> at'' and
''~ <=> tilde'' are forgotten), but you (-> Wolfram research) must
be joking, ''Mathematica 3.0 for Linux''-users are to continuously
''navigate'' between keyboard and mouse, whenever they want to put
in ''[]{}''-characters --- probably the most frequently characters
of the Mathematica language! That's anything else but convenient and
effective. > > I've found another solution-description on the web-site
of my Linux-distributer > (see:
However, I couldn't make it run on my system; perhaps it only works
for earlier Mathematica-versions than 3.0, but possibly it helps somebody.
My question: Is there a similar way in V.3.0 to (re)define keys in
initialisation-files of the Mathematica-system? > > I propose another
interim solution for users, who cannot apply Friedhelm's way > to
fix the problem: Run ''loadkeys us'' on your Linux command-line as
root and then start ''X'' and Mathematica as user. Now you will have
an fine-working US-keyboard until you run the loadkeys-system-tool
again with another keytable option (e.g. ''de-latin1'' for german
keybords) (...or restart your machine). Disadvantage: You have to
learn the new keyboard-mapping, other applications will have an US-keyboard,
> too, and, of course, special chars like the german ''Umlaute'' won't
work (use palettes). > > So my urgent wish to Wolfram-research is,
that you will soon find a proper > bug-fix; it'd be a pity, if this
tiny, but even more annoying bug avoids Linux > users to ''taste''
the really great fun (!!!) of Mathematica 3.0... > > Bye! i am using
mathematica 3.0 for students on my linux 2.0.x system, i tryed the
modification of the xmodmap, and it works fine. for using all keys
on my german keyboard (including the german umlaute), i (additionaly)
modifyed the event translation file /usr/local/mathematica/SystemFiles/FrontEnd/TextResources/
by inserting Item[KeyEvent[udiaeresis],FrontEndExecute[{ FrontEnd`NotebookWrite[FrontEnd`SelectedNotebook[],
'''', After]}]], Item[KeyEvent[Udiaeresis],FrontEndExecute[{ FrontEnd`NotebookWrite[FrontEnd`SelectedNotebook[],
'''', After]}]], Item[KeyEvent[adiaeresis],FrontEndExecute[{ FrontEnd`NotebookWrite[FrontEnd`SelectedNotebook[],
'''', After]}]], Item[KeyEvent[Adiaeresis],FrontEndExecute[{ FrontEnd`NotebookWrite[FrontEnd`SelectedNotebook[],
'''', After]}]], Item[KeyEvent[odiaeresis],FrontEndExecute[{ FrontEnd`NotebookWrite[FrontEnd`SelectedNotebook[],
'''', After]}]], Item[KeyEvent[Odiaeresis],FrontEndExecute[{ FrontEnd`NotebookWrite[FrontEnd`SelectedNotebook[],
'''', After]}]], Item[KeyEvent[ssharp],FrontEndExecute[{ FrontEnd`NotebookWrite[FrontEnd`SelectedNotebook[],
'''', After]}]], in the EventTranslation list. the ''udiaeresis''
is the symbol mathematica gets, when pressing (look at te x enviroment
information->find keys and modifyers, if this doesen't work). hope
this helps bye

URL: ,
Help | Reply To Topic