Mathematica 9 is now available
Student Support Forum
-----
Student Support Forum: 'Linux Num Lock' topicStudent Support Forum > General > "Linux Num Lock"

Help | Reply To Topic
Author Comment/Response
Scott
08/09/01 02:13am

I just installed Mathematica for Students 4.1 under Red Hat Linux. Everythung works fine, except [Num Lock] acts as a global select, effectively keeping me from using my keyboard's number pad. (mod2 is mapped to the Num Lock key.)

The fix suggested by Mathematica's Help feature is to use the program xmodmap from bash, but I'm not sure how (yes, I've read the man page).

Tech support says,

"... Finally, if you wish to have NumLock pressed while working with Mathematica,
you may want to create an .Xdefaults file and place it in your home directory.
Its contents should be as follows:

! Set these if you need to change what the FE uses for Primary (Command)
! and Secondary (Option) modifier keys.
!
XMathematica*primaryModifierMask: Mod1Mask
XMathematica*secondaryModifierMask: Mod3Mask"

What does that mean? Is there a reference I can get to find out? I'm a little leery of screwing something up, as I'm new to Linux.

If anyone has had this problem, please advise.

Thanks,

Scott

URL: ,
Help | Reply To Topic