MathGroup Archive 1996

[Date Index] [Thread Index] [Author Index]

Search the Archive

Linear Regression

  • To: mathgroup at
  • Subject: [mg3748] Linear Regression
  • From: rhall2 at (hall robert)
  • Date: Sun, 14 Apr 1996 03:02:12 -0400
  • Organization: University of Maryland, Baltimore County
  • Sender: owner-wri-mathgroup at

I'm having a problem with the Linear Regression package. I ran
a regression with 1 independent variable and a sample size of 28.
Then I tried to do a Ramsey RESET. This involves taking 
a list of predicted outcomes and raising it to the 2nd, 3rd
and 4th powers. Theses 3 new lists are then used as additional
independent variables (I'm now up to 4 independent variables)
and the regression is run again. The increase in independent
variables should always result in a lower sum of squares due
to error. The ANOVA table showed a sum of squares due to error
that was larger than the 1st regression by a factor of about 100.

Secondly, I thought the FitResidual list was a list of the
differences between the observed outcomes and the predicted
outcomes. A little calculation shows that this isn't the case.
Can anyone tell me what FitResidual is?

I tried the Econometrics package. The variances were better
behaved but the coefficients are not the result of OLS. I
tried a small sample by hand, using Fit[], Regress[], and
Reg[]. The coefficients derived by hand matched those from
Fit[] and Regress[], but the output from Reg[] was quite
different. (I used "const" instead of entering an
intercept list.)

Can somebody clue me in?

By the way, I got a badly conditioned matrix warning
when I ran the RESET regression with Reg[]. I changed
the algorithm option to SVD, but the output data didn't
change. I got no warnings from Regress[].


Bob Hall            | "Know thyself? Absurd direction!
rhall2 at  |  Bubbles bear no introspection."  -Khushhal Khan Khatak


  • Prev by Date: RE: DSolveConstants question
  • Next by Date: Opening files of Mma 2.2.3 on Win95
  • Previous by thread: Help Wanted
  • Next by thread: Opening files of Mma 2.2.3 on Win95