MathGroup Archive 1996

[Date Index] [Thread Index] [Author Index]

Search the Archive

Re: Loading packages w/o write access

  • To: mathgroup at
  • Subject: [mg4486] Re: Loading packages w/o write access
  • From: voorhorst at (Wolfram Jr.)
  • Date: Mon, 29 Jul 1996 02:37:35 -0400
  • Organization: TU delft
  • Sender: owner-wri-mathgroup at

In article <4snbva$rra at>, Ruby Tuesday
<hopie at> wrote:

> I am running mathematica on a multi-user unix machine (Sun and HP - account
> on both).  I need to load several packages that are not in the /Packages
> directory.  Since I do not have write access to that directory (and the
> admins are to slow to add it in time), I was wondering how to load the
> package from my home dir?
> I have tried changing the working diretory, but it doesn't seem to stay
> changed - even placing it in the same cell as my Get.  The closest I
> have come in executing Get["/my/home/dir/PackageName.m"] but it didn't 
> allow me to use the commands; it just didn't give an error either.
> Also, could someone explain how to interpret <<Graphis`PackageName`?  I
> am thinking Graphics is the subdirectory under packages, but then it
> would seem I could do <<my/home/dir`Package` which doesn't work.  I even
> tried changing the line in the package that says "Graphics`PackageName` to
> many differnt things.  Well, to make a long stroy short, I spent about 5 
> hours yesterday cursing at the computer.
> The Mathematica Book suggested
> reinstalling if $Path was not correct, since $Path was where it looked for
> packages.  This is not an option.  Is there a .rc file I could change?
> Is there any hope for me loading these packages or should I just go to the
> computer lab?
> Thank you very much!
> Hope :)

I do not have experience with Unix. Why is $Path not an option? If $path
is not choosy about "read only" than you can try 


Then: " Needs[Package`]" might work.



  • Prev by Date: reverse an axis
  • Next by Date: Re: Re: c code generation
  • Previous by thread: Re: reverse an axis
  • Next by thread: Loading packages w/o write access