MathGroup Archive 2001

[Date Index] [Thread Index] [Author Index]

Search the Archive

Re: Linux font problem

  • To: mathgroup at
  • Subject: [mg31739] Re: [mg31719] Linux font problem
  • From: "P.J. Hinton" <paulh at>
  • Date: Thu, 29 Nov 2001 00:14:20 -0500 (EST)
  • Organization: "Wolfram Research, Inc."
  • Sender: owner-wri-mathgroup at

On Wed, 28 Nov 2001, me wrote:

> SuSE Linux 7.3, Mathematica 4.1
> Right after the initial splash screen, I get a "startup warning", where all
> of the characters in the actual warning appear as small boxes...
> If I select the one that promises to be "ok", mathematica starts, but
> almost every character on the display is one of those little square boxes..
> I've tried adding the mathematica fonts to the /etc/XF86Config file, like
> this:
>  FontPath      "/usr/X11R6/lib/X11/fonts/xtest"
>   FontPath      "/usr/local/mathematica/SystemFiles/Fonts/X/"
>   FontPath      "/usr/local/mathematica/SystemFiles/Fonts/Type1/"
>   FontPath      "/usr/local/mathematica/SystemFiles/Fonts/AFM/"
>   ModulePath    "/usr/X11R6/lib/modules"
> and it doesn't help...
> reinstalled, rebooted, no luck....
> X display of mathematica from another working machine does exactly the same
> thing.... the little boxes display instead of readable characters...
> Nothing in my .Xdefaults file, have also tried using kde and mwm... same
> result with both window managers..   Didn't see anything useful at
> either....
> Stumped..., puzzled... Thanks in advance for any help on this one !

First of all, remove the directory:


from your X server's font path.  This directory contains Adobe font metric
files for generating PostScript in EPS files and print jobs.  They are not
usable by the X server.  Also, reverse the ordering of the Type1 and X
directories.  The outline fonts in the Type1 directory should appear first
on the font path for optimal performance.

Once this configuration is adjusted, check to see if the Math fonts appear
on the list of available fonts.  This is done with the xlsfonts command.

	xlsfonts | grep ^-wri > /tmp/wrifonts.txt

Open the file /tmp/wrifonts.txt in your favorite text editor.  This should
tell whether or not the fonts are available to your X server.  If they
are not, try adding the directories to the math fonts by hand.

	xset fp+ /usr/local/mathematica/SystemFiles/Fonts/Type1
	xset fp+ /usr/local/mathematica/SystemFiles/Fonts/X

Once the fonts are available, check to see how many fonts are available to
the X server:

	xlsfonts | wc -l

This should return a positive integer value.  If this number is greater
than 2000, then you will need to make a change to a Mathematica text
resource file.  The steps are described in detail at this URL:

If you still encounter font problems after these steps, please repost to
this forum with a precise description of what error messages and anomalous
behavior you observe.

P.J. Hinton
User Interface Programmer                         paulh at
Wolfram Research, Inc.
Disclaimer: Opinions expressed herein are those of the author alone.

  • Prev by Date: Re: problems with editing
  • Next by Date: Re: Virus Warning for email by Tomas Garza
  • Previous by thread: Re: Linux font problem
  • Next by thread: Re: making a function of two coordinates