MathGroup Archive 2002

[Date Index] [Thread Index] [Author Index]

Search the Archive

Mathematica for Linux font problem on SuSE7.3

  • To: mathgroup at
  • Subject: [mg32497] Mathematica for Linux font problem on SuSE7.3
  • From: willie cronje <waccronje at>
  • Date: Wed, 23 Jan 2002 01:00:26 -0500 (EST)
  • Reply-to: wacronje at
  • Sender: owner-wri-mathgroup at

To whom it may concern/anybody who can help

After installing Mathematica 4.1 on my HP notebook with newly installed
SuSE7.3 I have not been able to use it at all.

I have been searching and reading all mail threads of this group
relating to this type of problem and after learning a lot about fonts
and installations and performing lots of changes on my system and
experimenting with some other I still don't manage to get Mathematica to
work (or rather work work in a useable way).

Initially I got some error messages (two after each other) that I could
not read because the letters displayed as little boxes!

I managed to override this by specifying the -font  option on the
command line when starting Mathematica. I could use many different fonts
here (as obtained fron xfontsel) and the error messages and menus became
readable. But typing into a blank notebook only produced boxes.

The first error message said fonts are not correctly installed and using
this as a hint I started searching on the Wolfram site. I discovered
some usefull information and changed my XF86Config file to include the
Mathematica font files.

The error message about the fonts now no longer appeared but nothing
else changed.
I can now actually view the wri fonts in xfontsel and assume they are
correctly installed.

I also changed the setting for  maxForXListFonts in to 7000,
which is anumber larger than the number reported by xlsfonts | wc -l.

Mathematica remained useles because I could now only type math
characters into a notebook!!

The second error message still persisted and complained about not
finding a character encoding file for iso10646-1.

I searched the Wolfram site once more and found more information.

I tried to remove any exotic character sets. This did not bring any joy

I read the mail from Dr. Hans Ekkehard Plesser and followed his
suggestions to really remove all encoding that do not correspond to
Mathematica encodings. I also made the symbolic link he suggested,

Now the error message about iso10646-1 encoding no longer appears bu
Mathematica is still not functional. The menus now only display the
first character and typing into a notebook only produces boxes and math

Does anybody have any further suggestions?

I am in desperate need of help, this is taking me reaaly far from the
reason I want to use Mathematica. 


	Prof.W.A. Cronje		Tel:+27-11-489-2602
	Rand Afrikaans University	Fax:+27-11-489-2602
	P.O. Box 524			e-mail:wacronje at
	Aucklandpark 2006
	South Africa

  • Prev by Date: Re: Why doesn't this rule work?
  • Next by Date: Mathematica for Linux font problem on SuSE7.3
  • Previous by thread: Re: memoizing function again
  • Next by thread: Mathematica for Linux font problem on SuSE7.3