MathGroup Archive 2004

[Date Index] [Thread Index] [Author Index]

Search the Archive

Re: launching a kernel on a remote linux machine through ssh from a linux machine

  • To: mathgroup at
  • Subject: [mg52533] Re: [mg52381] launching a kernel on a remote linux machine through ssh from a linux machine
  • From: Arturas Acus <acus at>
  • Date: Wed, 1 Dec 2004 05:57:53 -0500 (EST)
  • References: <>
  • Sender: owner-wri-mathgroup at

Hi Walter,

 on my machine I launch remote kernel with the following settings

Arguments to pass to MLOpen:

-LinkMode Connect -LinkProtocol TCP -LinkName "3007" -LinkHost

String to launch kernel
ssh  user at "math" -mathlink -LinkMode Listen
-LinkProtocol TCP -LinkName "3007" -LinkHost

Instead of "3007" you can chose any other port, which is used to data
transfer. I have heard that there may be problems if your remote host is
after fireware, which dissalow use of these high ports. 

Just note. that I use Listen for ssh started kernel and pass Connect to
MLOpen. You do it in different order. This not worked for me.

Also I marked "translate returns" box.

On Kt, 2004-11-25 at 05:49 -0500, walter wrote:
> Greetings:
> I am trying to launch a kernel on a faster linux machine (call it
> "", IP address "") and connect it to my local
> front end (on "", IP address ""). Both run
> Mathematica on Fedora Linux (3 and 2, respectively). The
> connection goes through ssh.
> On the front end on I now try to add a kernel with
> "Kernel Configuration Options...".
> If I select as the remote machine the same as my local machine
> "", everything works fine. I know I could do this without
> going through TCP/IP, but just for checking it out:
>    Arguments passed to MLOpen:
>       -LinkMode Listen -LinkProtocol TCPIP
>    String passed to shell to launch kernel:
>       ssh "math -mathlink -LinkMode Connect
> -LinkProtocol TCPIP -LinkName `linkname`"
> Choosing this to be the notebook's kernel, once I execute the first
> calculation it pops up a box saying "Link created on
> 35945 at,35946 at", then asks for the password for
>, and everything works fine; I can run calculations as
> usual.
> The problem appears when I change the above string to
>       ssh "math -mathlink -LinkMode Connect
> -LinkProtocol TCPIP -LinkName `linkname`"
> (note that only the computer name has changed). When I do the first
> calculation, I still get a box saying "Link created on
> 35950 at,35951 at", then one asking for the password for
> But then it stops doing anything. The result is that I
> have no kernel running, neither on nor on,
> and no result is being displayed.
> Does anyone know what I'm doing wrong? I've been searching through old
> messages on this forum and could not figure it out.
> Thanks!
>      Walter.
Arturas Acus <acus at>

  • Prev by Date: Re: New User - Programming
  • Next by Date: Re: Re: canonical mathematical expression represenation?
  • Previous by thread: Re: launching a kernel on a remote linux machine through ssh from a linux machine
  • Next by thread: Re: Finding the Fourier transform of discrete functions