MathGroup Archive 2006

[Date Index] [Thread Index] [Author Index]

Search the Archive

Re: Possible Bug in ArcTan ?

  • To: mathgroup at
  • Subject: [mg64784] Re: Possible Bug in ArcTan ?
  • From: "Jens-Peer Kuska" <kuska at>
  • Date: Thu, 2 Mar 2006 19:28:04 -0500 (EST)
  • Organization: Uni Leipzig
  • References: <du6o44$5rg$>
  • Sender: owner-wri-mathgroup at


why can ArcTan[] have two arguments ArcTan[x,y] 


"JCDenton" <post4uw at> schrieb im Newsbeitrag 
news:du6o44$5rg$1 at
| Hi Group!
| I am describing resonant electrical systems with 
Mathematica. So there
| is a lot of dealing with complex numbers and 
functions. One important
| function is:
| phi=ArcTan[Im/Re]
| This function is zero when Im = 0. The problem 
is, that when I plot
| this function it shows some strange behaviour 
near this zero point. It
| looks somehow, as if the function values are 
multiplied with -1 or
| something like that. I also tried to calculate a 
table an plot this
| with gnuplot where the stepsize was 0.005. I was 
the same strange
| situation. So I am sure it is not the Plot 
function that is buggy but
| the ArcTan itself. I also tried the table with 
step size 0.05 and I get
| the "right" picture with gnuplot. Is this a 
known bug? I have not found
| something about it yet.
| I realy need this function, since it is a very 
important operation in
| complex calculation.
| Thank you!

  • Prev by Date: Re: Fourier Transforms
  • Next by Date: Plot[] of smooth function results in wildly fluctuating graph?
  • Previous by thread: Re: Possible Bug in ArcTan ?
  • Next by thread: Re: Possible Bug in ArcTan ?