MathGroup Archive 2006

[Date Index] [Thread Index] [Author Index]

Search the Archive

Re: Re: Possible Bug in ArcTan ?

  • To: mathgroup at
  • Subject: [mg64820] Re: [mg64793] Re: [mg64770] Possible Bug in ArcTan ?
  • From: "Dr Andy D Kucar PEng" <andy at>
  • Date: Sat, 4 Mar 2006 02:35:42 -0500 (EST)
  • Reply-to: <andy at>
  • Sender: owner-wri-mathgroup at

Subject: [mg64820] ArcTan[x,y], i.e., phase plot

Some time ago, I reported similar problem,
while calculating and plotting the phase of some functions
involving Jacobi and Weierstrass elliptic functions

I "observed" some strange chaotic noisy behavior near zero/ small values of phase
David Park helped me with some graphic aspects, thanks.

As yet, I have not fully solved the problem,
I circumvented it
However, the problem has not been with Mathematica algorithms, per se
It appears, "my" graphics coprocessor does some short cuts, i.e., approximations,
And this strange behavior might be OS state related
Or, perhaps more precisely, graphics+CPU approximations ...
Similar graphics related problems were reported somewhere else, outside Mathematica environment

Sincerely Andy

-----Original Message-----
From: David Park [mailto:djmp at]
To: mathgroup at
Subject: [mg64820] [mg64793] Re: [mg64770] Possible Bug in ArcTan ?

Try the two argument form of ArcTan, ArcTan[x,y].

David Park
djmp at

From: JCDenton [mailto:post4uw at]
To: mathgroup at

Hi Group!

I am describing resonant electrical systems with Mathematica. So there
is a lot of dealing with complex numbers and functions. One important
function is:


This function is zero when Im = 0. The problem is, that when I plot
this function it shows some strange behaviour near this zero point. It
looks somehow, as if the function values are multiplied with -1 or
something like that. I also tried to calculate a table an plot this
with gnuplot where the stepsize was 0.005. I was the same strange
situation. So I am sure it is not the Plot function that is buggy but
the ArcTan itself. I also tried the table with step size 0.05 and I get
the "right" picture with gnuplot. Is this a known bug? I have not found
something about it yet.

I realy need this function, since it is a very important operation in
complex calculation.

Thank you!

  • Prev by Date: Re: Possible Bug in ArcTan ?
  • Next by Date: Re: Fourier Transforms
  • Previous by thread: Re: Possible Bug in ArcTan ?
  • Next by thread: Re: Possible Bug in ArcTan ?