MathGroup Archive 2007

[Date Index] [Thread Index] [Author Index]

Search the Archive

Re: Re: SphericalPlot3D doesn't work

  • To: mathgroup at
  • Subject: [mg74343] Re: [mg74321] Re: SphericalPlot3D doesn't work
  • From: Jmbatista at
  • Date: Mon, 19 Mar 2007 02:04:17 -0500 (EST)

David, I'm not sure if this is an old message.  But, just in case you still 
need some help, I tried running your program and found no problems.  To make a 
cylindrical or spherical plot, you first need to execute the following command:
This command will load the standard package ParametricPlot3D.m.
Then, you will need to execute the following command:
    SphericalPlot3D[2, {theta, 0, Pi}, {phi, -Pi, Pi}];
This should produce the results you are looking for.  If you need a soft copy 
of the notebook that I created, please let me know.
Best Regards,
J. Batista
In a message dated 3/18/2007 2:18:49 AM Eastern Daylight Time, 
petsie at writes:

David schrieb:
> SphericalPlot3D doesn't work for me.
> I HAVE loaded the graphics package. it just returns the same input as 
though I am defining a function:
> IN: << Graphics`ParametricPlot3D`
>     SphericalPlot3D[2, {theta, 0, Pi}, {phi, -Pi, Pi}]
> OUT: SphericalPlot3D[2, {theta, 0, Pi}, {phi, -Pi, Pi}]
> I've seen that other people have had this problem but I haven't seen a 
solution anywhere.
> Please help, cheers,
> Dave

Hi Dave,

maybe you tried to call SphericalPlot3D before loading
Graphics`ParametricPlot3D`? In that case there are two functions named
SphericalPlot3D  in two different contexts. If you do not want to restart the
kernel, try Remove["Global`SphericalPlot3"];


************************************** AOL now offers free email to everyone. 
 Find out more about what's free from AOL at

  • Prev by Date: Re: Noob evaluation question
  • Next by Date: Re: How to choose real positive solutions only?
  • Previous by thread: Re: SphericalPlot3D doesn't work
  • Next by thread: Normal for Limit