MathGroup Archive 2007

[Date Index] [Thread Index] [Author Index]

Search the Archive

Re: PlotLabel - SubscriptBox - Vers. 6: FontColor not working?

  • To: mathgroup at
  • Subject: [mg83734] Re: PlotLabel - SubscriptBox - Vers. 6: FontColor not working?
  • From: Thomas BOHL <Thomas.Bohl at>
  • Date: Thu, 29 Nov 2007 06:28:06 -0500 (EST)
  • References: <figuaf$fhv$> <>

Hi Kevin,

thanks for your suggestion to pointing out the SingleLetterItalics->True
option, of which I was not aware.

I changed this option with the OptionsInspector but it did not have any
influence on the axis label.

Thanks again for pointing out this option SingleLetterItalics but I
think I give up about the FontSlant for the moment.

Thank you very much and kind regards,

Syd Geraghty wrote:
> Hi Thomas,
> Deleting the "" on Subscript works OK as does "Oblique" on FontSlant.
> ListPlot[Table[Random[], {10}],
>  AxesLabel -> {Style[Subscript[f, RF], FontSlant -> "Oblique",
>     FontColor -> Red], Style["y-axis", FontColor -> Red]}]

Kevin J. McCann wrote:
> I tried this with 6.0.1 under WXP-SP2 and it works as you might expect, 
> i.e. in color. The Italics are due to SingleLetterItalics->True in 
> either the Core or Default nb. I could not figure out how to get around 
> these myself. I tried all sorts of things to get rid of the Italics. So, 
> I did the unthinkable - I edited Core to change all those to False. I 
> also got rid of the annoying Courier fonts that show up in equations.
> Kevin

> Thomas BOHL wrote:
>> Dear all,
>> switching over to Mathematica Version 6 ( on Linux x86 (SLC4) 
>> I have a number of problems which I did not have with previous 
>> versions of Mathematica. One is the following:
>> ListPlot[Table[Random[], {10}],
>> AxesLabel -> {Style["Subscript[f, RF]", \
>> FontSlant->Plain, FontColor->Red],Style[ \
>> "y-axis", FontColor->Red]} ]
>> ... does not produce an x axis label as expected. What I would expect is
>> a label with a the FontSlant as indicated and of FontColor as indicated.
>> However, the label is written with "f" in italic, the subscript in plain
>> and both in a colour of light grey.
>> The y axis label (no Subscript) is as expected.
>> With the same code on Windows XP at least the FontColor is as specified,
>> the FontSlant is also here not as specified (but I could live with that
>> if I have to).
>> In summary there are two problems for me with Subscript (on Linux):
>> - the FontSlant specification is not working
>> - the FontColor specification is not working
>> Could somebody please give me hint how to get at least FontColor working
>> on Linux?
>> Thank you very much and kind regards,
>> Thomas.
>> P.S.
>> 1)The result of a cell command (not as label)
>> Style["Subscript[f, RF]",\
>> FontSlant->"Plain",FontColor->Red]
>> is of correct FontSlant but the FontColor is still incorrect and using
>> the same Mathematica expression in a label changes the FontSlant of the
>> letter "f" to italic and the FontColor is of course still wrong (light
>> grey).
>> 2)
>> Also LabelStyle->Red does not change the colour of a subscripted 
>> expression.

  • Prev by Date: Re: Epilog with 3 dimensional graphics primitives
  • Next by Date: Re: is the visibility of a Polygon[] exposed?
  • Previous by thread: Re: Re: PlotLabel - SubscriptBox - Vers. 6: FontColor not
  • Next by thread: Palette Entry - Recognize Style Sheet?