MathGroup Archive 2013

[Date Index] [Thread Index] [Author Index]

Search the Archive

Integrating piecewise functions.

  • To: mathgroup at
  • Subject: [mg120024] Integrating piecewise functions.
  • From: mrkhrdr at
  • Date: Tue, 5 Mar 2013 04:20:05 -0500 (EST)
  • Delivered-to:
  • Delivered-to:
  • Delivered-to:
  • Delivered-to:

I have been trying to get a meaningful solution to the differential eqn. for the voltage and current in an inductor:
V[t] == -L i'[t].  For smooth voltage waveforms, the current function is well-behaved and a reasonable solution.  But when V[t] is a piecewise function, either my own, or one of the built-in ones, such as SquareWave, the solutions obtained are unreasonable.  They may satisfy the differential equation, but they increase in magnitude without limit.  I tried integrating the SquareWave[t] Mathematica function, and I could see why DSolve was probably having a problem.  The square wave has values +1 or -1 on each half-cycle.  Integrate[] sees these constants in the Piecewise statement and simple-mindedly replaces them with +t and -t.  So as t gets larger or smaller, the integral(s) yield ramp functions that alternate in sign during every half-cycle of the square wave.  What Integrate should yield is a positive-going ramp on the + half-cycle, and a decreasing positive-valued ramp on the - half-cycle of the square wave.  The correct function should be the sum of SquareWave[t]*dt over
  t.  The
  integrals created over each (continuous, differentiable) half-cycle should then be added to create a new function.  I can't figure out how to implement Integrate on piecewise functions like this.  Does anyone know how?

P.S.  I couldn't find a way to search MathGroup postings from the group's pages, so I may be posting an already solved problem.  If so, please let me know how I can use the group more efficiently.

  • Prev by Date: Re: How to find the roots of non linear equations
  • Next by Date: Re: How to find the roots of non linear equations
  • Previous by thread: Re: Import of URL no longer works in V9
  • Next by thread: Alternative to Table