MathGroup Archive 2013

[Date Index] [Thread Index] [Author Index]

Search the Archive

MarcumQ function

  • To: mathgroup at
  • Subject: [mg130688] MarcumQ function
  • From: Donagh Horgan <donagh.horgan at>
  • Date: Wed, 1 May 2013 21:43:31 -0400 (EDT)
  • Delivered-to:
  • Delivered-to:
  • Delivered-to:
  • Delivered-to:


I recently upgraded to Mathematica 9, and I've noticed a problem with the MarcumQ function. The following command should illustrate it:

Plot[{MarcumQ[100, 10, x], 1 - MarcumQ[100, 10, 0, x]}, {x, 0, 30}]

While the two functions are mathematically equivalent, the second incorrectly evaluates to zero between (approximately) x = 14 and x = 17.

The problem only seems to occur when the first parameter is large. For example, the command

Plot[{MarcumQ[50, 10, x], 1 - MarcumQ[50, 10, 0, x]}, {x, 0, 30}]

evaluates correctly, while the command

Plot[{MarcumQ[51, 10, x], 1 - MarcumQ[51, 10, 0, x]}, {x, 0, 30}]

does not.

I've tried wrapping the functions with the N command, e.g. N[f, 100], but the same problem occurs. I've also tried increasing $MaxExtraPrecision and $WorkingPrecision using Block, but with no luck.

I've been testing my old code since I upgraded from Mathematica 8 a few days ago, so the error appears (to me, at least) to be new.

All suggestions greatly appreciated!

Best regards,
Donagh Horgan

  • Prev by Date: Formula Stirlinga
  • Next by Date: Re: NMF in Mathematica 8
  • Previous by thread: Re: Formula Stirlinga
  • Next by thread: Re: MarcumQ function